Bug 236926 - RFE: No option to allow network layer protocols (e.g. IGMP for multicast)
Summary: RFE: No option to allow network layer protocols (e.g. IGMP for multicast)
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-firewall   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-18 14:11 UTC by Kevin R. Page
Modified: 2013-11-06 19:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 19:32:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin R. Page 2007-04-18 14:11:35 UTC
Description of problem:
There's no option in the firewall configuration to allow further layer 3
protocols. e.g. to receive multicast streams (e.g. the BBC test streams) a PC
not only needs to allow the UDP ports for the stream itself, but to join and
communicate with the multicast group using IGMP. With incoming IGMP blocked, the
stream will cease as multicast group membership isn't maintained.

Using iptables, I might use:

iptables -I RH-Firewall-1-INPUT --protocol igmp --jump ACCEPT

It would therefore be useful to have an option to enable other network layer
protocols in system-config-securitylevel, or alternatively perhaps an way to add
options in /etc/sysconfig/


Version-Release number of selected component (if applicable):
system-config-securitylevel-1.6.27-1

Comment 1 Thomas Woerner 2007-09-24 14:13:31 UTC
Assigning to system-config-firewall in devel.

Comment 2 Jon Stanley 2008-04-23 20:28:49 UTC
Adding FutureFeature keyword to RFE's.

Comment 3 Thomas Woerner 2013-11-06 19:32:31 UTC
Closing because there will not be big changes to system-config-firewall anymore.


Note You need to log in before you can comment on or make changes to this bug.