Bug 23694 - up2date does not check if running on tty
up2date does not check if running on tty
Status: CLOSED DUPLICATE of bug 25223
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-10 01:34 EST by John Newbigin
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-10 01:34:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Newbigin 2001-01-10 01:34:31 EST
When run from a cron job or piped through less, all the % marks are still printed.  The result is a heap of usless numbers.  When output is not a 
teminal then the % progress should be skipped.


[root@cartman /root]# up2date --list | less

Retrieving list of all available packages...

Removing installed packages from list of updates...
0.077%^M0.154%^M0.232%^M0.309%^M0.386%^M0.464%^M0.541%^M0.618%^M0.696%^M0.773%^M0.850%^M0.928%^M1.005%^M1.082%
^M1.160%^M1.237%^M1.314%^M1.392%
1.469%^M1.546%^M1.624%^M1.701%^M1.778%^M1.856%^M1.933%^M2.010%^M2.088%^M2.165%^M2.242%^M2.320%^M2.397%^M2.474%
^M2.552%^M2.629%^M2.706%^M2.784%
2.861%^M2.938%^M3.016%^M3.093%^M3.170%^M3.248%^M3.325%^M3.402%^M3.480%^M3.557%^M3.634%^M3.712%^M3.789%^M3.866%
^M3.944%^M4.021%^M4.098%^M4.176%
4.253%^M4.331%^M4.408%^M4.485%^M4.563%^M4.640%^M4.717%^M4.795%^M4.872%^M4.949%^M5.027%^M5.104%^M5.181%^M5.259%
^M5.336%^M5.413%^M5.491%^M5.568%
5.645%^M5.723%^M5.800%^M5.877%^M5.955%^M6.032%^M6.109%^M6.187%^M6.264%^M6.341%^M6.419%^M6.496%^M6.573%^M6.651%
^M6.728%^M6.805%^M6.883%^M6.960%
7.037%^M7.115%^M7.192%^M7.269%^M7.347%^M7.424%^M7.501%^M7.579%^M7.656%^M7.733%^M7.811%^M7.888%^M7.965%^M8.043%
^M8.120%^M8.197%^M8.275%^M8.352%
8.430%^M8.507%^M8.584%^M8.662%^M8.739%^M8.816%^M8.894%^M8.971%^M9.048%^M9.126%^M9.203%^M9.280%^M9.358%^M9.435%
^M9.512%^M9.590%^M9.667%^M9.744%
9.822%^M9.899%^M9.976%^M10.05%^M10.13%^M10.20%^M10.28%^M10.36%^M10.44%^M10.51%^M10.59%^M10.67%^M10.75%^M10.82%
^M10.90%^M10.98%^M11.05%^M11.13%
11.21%^M11.29%^M11.36%^M11.44%^M11.52%^M11.60%^M11.67%^M11.75%^M11.83%^M11.91%^M11.98%^M12.06%^M12.14%^M12.21%
^M12.29%^M12.37%^M12.45%^M12.52%
12.60%^M12.68%^M12.76%^M12.83%^M12.91%^M12.99%^M13.07%^M13.14%^M13.22%^M13.30%^M13.37%^M13.45%^M13.53%^M13.61%
^M13.68%^M13.76%^M13.84%^M13.92%
13.99%^M14.07%^M14.15%^M14.23%^M14.30%^M14.38%^M14.46%^M14.53%^M14.61%^M14.69%^M14.77%^M14.84%^M14.92%^M15.00%
^M15.08%^M15.15%^M15.23%^M15.31%
15.39%^M15.46%^M15.54%^M15.62%^M15.69%^M15.77%^M15.85%^M15.93%^M16.00%^M16.08%^M16.16%^M16.24%^M16.31%^M16.39%
^M16.47%^M16.55%^M16.62%^M16.70%
16.78%^M16.86%^M16.93%^M17.01%^M17.09%^M17.16%^M17.24%^M17.32%^M17.40%^M17.47%^M17.55%^M17.63%^M17.71%^M17.78%
^M17.86%^M17.94%^M18.02%^M18.09%
18.17%^M18.25%^M18.32%^M18.40%^M18.48%^M18.56%^M18.63%^M18.71%^M18.79%^M18.87%^M18.94%^M19.02%^M19.10%^M19.18%
^M19.25%^M19.33%^M19.41%^M19.48%
19.56%^M19.64%^M19.72%^M19.79%^M19.87%^M19.95%^M20.03%^M20.10%^M20.18%^M20.26%^M20.34%^M20.41%^M20.49%^M20.57%
^M20.64%^M20.72%^M20.80%^M20.88%
20.95%^M21.03%^M21.11%^M21.19%^M21.26%^M21.34%^M21.42%^M21.50%^M21.57%^M21.65%^M21.73%^M21.80%^M21.88%^M21.96%
^M22.04%^M22.11%^M22.19%^M22.27%
22.35%^M22.42%^M22.50%^M22.58%^M22.66%^M22.73%^M22.81%^M22.89%^M22.96%^M23.04%^M23.12%^M23.20%^M23.27%^M23.35%
^M23.43%^M23.51%^M23.58%^M23.66%
23.74%^M23.82%^M23.89%^M23.97%^M24.05%^M24.12%^M24.20%^M24.28%^M24.36%^M24.43%^M24.51%^M24.59%^M24.67%^M24.74%
^M24.82%^M24.90%^M24.98%^M25.05%
25.13%^M25.21%^M25.29%^M25.36%^M25.44%^M25.52%^M25.59%^M25.67%^M25.75%^M25.83%^M25.90%^M25.98%^M26.06%^M26.14%
^M26.21%^M26.29%^M26.37%^M26.45%
26.52%^M26.60%^M26.68%^M26.75%^M26.83%^M26.91%^M26.99%^M27.06%^M27.14%^M27.22%^M27.30%^M27.37%^M27.45%^M27.53%
^M27.61%^M27.68%^M27.76%^M27.84%
27.91%^M27.99%^M28.07%^M28.15%^M28.22%^M28.30%^M28.38%^M28.46%^M28.53%^M28.61%^M28.69%^M28.77%^M28.84%^M28.92%
^M29.00%^M29.07%^M29.15%^M29.23%
29.31%^M29.38%^M29.46%^M29.54%^M29.62%^M29.69%^M29.77%^M29.85%^M29.93%^M30.00%^M30.08%^M30.16%^M30.23%^M30.31%
^M30.39%^M30.47%^M30.54%^M30.62%
30.70%^M30.78%^M30.85%^M30.93%^M31.01%^M31.09%^M31.16%^M31.24%^M31.32%^M31.39%^M31.47%^M31.55%^M31.63%^M31.70%
^M31.78%^M31.86%^M31.94%^M32.01%
32.09%^M32.17%^M32.25%^M32.32%^M32.40%^M32.48%^M32.55%^M32.63%^M32.71%^M32.79%^M32.86%^M32.94%^M33.02%^M33.10%
^M33.17%^M33.25%^M33.33%^M33.41%
33.48%^M33.56%^M33.64%^M33.72%^M33.79%^M33.87%^M33.95%^M34.02%^M34.10%^M34.18%^M34.26%^M34.33%^M34.41%^M34.49%
^M34.57%^M34.64%^M34.72%^M34.80%
34.88%^M34.95%^M35.03%^M35.11%^M35.18%^M35.26%^M35.34%^M35.42%^M35.49%^M35.57%^M35.65%^M35.73%^M35.80%^M35.88%
^M35.96%^M36.04%^M36.11%^M36.19%
36.27%^M36.34%^M36.42%^M36.50%^M36.58%^M36.65%^M36.73%^M36.81%^M36.89%^M36.96%^M37.04%^M37.12%^M37.20%^M37.27%
^M37.35%^M37.43%^M37.50%^M37.58%
37.66%^M37.74%^M37.81%^M37.89%^M37.97%^M38.05%^M38.12%^M38.20%^M38.28%^M38.36%^M38.43%^M38.51%^M38.59%^M38.66%
^M38.74%^M38.82%^M38.90%^M38.97%
3
Comment 1 Preston Brown 2001-02-09 00:27:07 EST

*** This bug has been marked as a duplicate of 25223 ***

Note You need to log in before you can comment on or make changes to this bug.