Bug 236946 - ImportError: cannot import name CreateInputSource
Summary: ImportError: cannot import name CreateInputSource
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-amara   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: José Matos
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-18 16:54 UTC by Sergio Monteiro Basto
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: python-amara-1.1.9-8.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-31 03:11:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sergio Monteiro Basto 2007-04-18 16:54:17 UTC
Description of problem:



Version-Release number of selected component (if applicable):


How reproducible:
yum -y install python-amara.noarch


Steps to Reproduce:
1. python
2. from amara import binderytools
3.
  
Actual results:
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/lib/python2.4/site-packages/amara/__init__.py", line 7, in ?
    import binderytools
  File "/usr/lib/python2.4/site-packages/amara/binderytools.py", line 16, in ?
    from amara import bindery
  File "/usr/lib/python2.4/site-packages/amara/bindery.py", line 16, in ?
    from amara import domtools
  File "/usr/lib/python2.4/site-packages/amara/domtools.py", line 203, in ?
    from amara.saxtools import sax2dom_chunker
  File "/usr/lib/python2.4/site-packages/amara/saxtools.py", line 5, in ?
    from Ft.Xml import Domlette, Sax, CreateInputSource
ImportError: cannot import name CreateInputSource


Expected results:
import without errors 

Additional info:

fc6 updated

Comment 1 Sergio Monteiro Basto 2007-04-19 14:02:17 UTC
Delete CreateInputSource from line 5 of
/usr/lib/python2.4/site-packages/amara/saxtools.py

seems resolve my problem 

Comment 2 José Matos 2007-08-29 18:26:28 UTC
Does this still occurs?

I am unable to reproduce it either in rawhide or F-7.

As far as I remember this bug was related with 1.1.7, while the current 
version is 1.1.9.

If I do not receive an answer in two weeks I will close this bug as fixed.

Comment 3 Sergio Monteiro Basto 2007-08-31 03:11:09 UTC
after upgrade to F7 I don't have the problem, anymore. 


Note You need to log in before you can comment on or make changes to this bug.