Bug 236957 - NFS copies of huge files does not complete
NFS copies of huge files does not complete
Status: CLOSED DUPLICATE of bug 228569
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Red Hat Real Time Maintenance
Depends On:
  Show dependency treegraph
Reported: 2007-04-18 13:35 EDT by IBM Bug Proxy
Modified: 2008-02-27 14:58 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-04-18 22:26:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
rtgroups_nfs_safe.patch (484 bytes, text/plain)
2007-05-07 00:36 EDT, IBM Bug Proxy
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 34017 None None None Never

  None (edit)
Description IBM Bug Proxy 2007-04-18 13:35:45 EDT
LTC Owner is: ankigarg@in.ibm.com
LTC Originator is: ankigarg@in.ibm.com

While trying to duplicate bug #26701 (a LTC internal bug, an NFS problem on the
2.6.16 RT kernel not recreatable on 2.6.17), found that NFS copy of huge files
does not complete on RHEL5 RT. This is a priority issue and would mostly be
fixed once the IRQ priority values are finalized on RHEL5 RT. So, keeping the
priority low till set_kthread_prio values are decided upon. Will test it once
that is done.

This can recreated as follows: 

Requires 3 systems on RHEL5 RT. On system A, nfs mount a directory structure on
B & C. From, A, nfs copy huge files, recursively, from B to C.

The IRQ priority values in set_kthread_prio-1.0-1.x86_64.rpm need to be adjusted
to correct this issue.

Discussion on this is happening on rhel-rt-external@redhat.com list. Mark Salter
from RedHat has worked on this.
Comment 2 IBM Bug Proxy 2007-05-07 00:30:57 EDT
----- Additional Comments From ankigarg@in.ibm.com (prefers email at ankita@in.ibm.com)  2007-05-07 00:29 EDT -------
By making changes to the priority values in the rtgroups file, part of
set_kthread_prio implementation, the NFS copies completed successfully.
Attaching a patch to the rtgroups file. 
Comment 3 IBM Bug Proxy 2007-05-07 00:36:13 EDT
Created attachment 154238 [details]
Comment 4 IBM Bug Proxy 2007-05-07 00:36:17 EDT
----- Additional Comments From ankigarg@in.ibm.com (prefers email at ankita@in.ibm.com)  2007-05-07 00:31 EDT -------
fix nfs related daemon priorities

Adjusting the priorities of the NFS related daemons, rpciod, lockd and nfsd,
ensures that these are not starved due to other rt threads. This would enable
the nfs related operations to complete. 
Comment 5 IBM Bug Proxy 2007-05-14 05:35:39 EDT

           What    |Removed                     |Added
             Status|ASSIGNED                    |FIXEDAWAITINGTEST
         Resolution|                            |FIX_BY_IBM

------- Additional Comments From ankigarg@in.ibm.com (prefers email at ankita@in.ibm.com)  2007-05-14 05:32 EDT -------
Marking this as FIXED_AWAITING_TEST so that RedHat can start on the process of
testing the suggested changes in the set_kthread_prio.conf (rtctl) values. 

Note You need to log in before you can comment on or make changes to this bug.