This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 236965 - Releasing DHCP lease and suspend/resume
Releasing DHCP lease and suspend/resume
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: dhcdbd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
: 236966 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-18 13:44 EDT by Paulus Esterhazy
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-21 14:51:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
syslog excerpt showing network-manager failure (2.69 KB, text/plain)
2007-04-18 13:44 EDT, Paulus Esterhazy
no flags Details

  None (edit)
Description Paulus Esterhazy 2007-04-18 13:44:57 EDT
Description of problem:
After hibernating, while using NetworkManager to manage a wired ethernet 
connection, NetworkManager fails to retrieve a DHCP IP address from dhcdbd, 
citing the error message "interface eth0 is being released. Please try again 
later." This isn't temporary, however, but persits until dhcdbp is restarted 
(sudo /etc/dbus-1/event.d/22dhcdbd restart). Alternatively, I can deactivate 
networking in NetworkManager and manually run "sudo dhclient eth0", which works 
instantly.

The problem is most likely dhcdbp going to a bad state. Dan Williams explains, 
"Apparently a dhcdbd bug, or some interaction between dhcdbd and
hibernate/suspend, possibly a race condition.  I'd bet that NM has told
dhcdbd to down the interface, and dhcdbd tried to release its acquired
address.  The machine goes to sleep during that operation, and when it
wakes up dhcdbd still thinks it's releasing the address, and doesn't let
any other operation happen."

Version-Release number of selected component (if applicable):
I'm using ubuntu feisty (just before its release).
dhcdbd 2.0-2ubuntu3
network-manager 0.6.4-6ubuntu7

How reproducible:
It happens every other suspend/resume cycle or so. After that, however, dhcdb 
stays indefinetly in its bad state.

Steps to Reproduce:
1.initiate suspend
2.resume
  
Actual results:
nm-applet shows that it's waiting for an IP address, and after a while stops

Expected results:
normal operation (IP address received)

Additional info:
I'm attaching a syslog excerpt which includes the output of manually running 
dhclient.
Comment 1 Paulus Esterhazy 2007-04-18 13:44:57 EDT
Created attachment 152933 [details]
syslog excerpt showing network-manager failure
Comment 3 David Cantrell 2007-04-19 14:58:22 EDT
*** Bug 236966 has been marked as a duplicate of this bug. ***
Comment 4 David Cantrell 2007-09-21 14:51:10 EDT
dhcdbd has been obsoleted by NetworkManager 0.7.0.

Note You need to log in before you can comment on or make changes to this bug.