Bug 237030 - Segfault in fixfiles/restorecon
Summary: Segfault in fixfiles/restorecon
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F7Test4
TreeView+ depends on / blocked
 
Reported: 2007-04-18 22:51 UTC by Will Woods
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 18:52:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Will Woods 2007-04-18 22:51:09 UTC
with policycoreutils-2.0.9-5.fc7, any invocation of fixfiles yields the
following message:
/sbin/fixfiles: line 130:  3954 Broken pipe             find $d ! \( -fstype
ext2 -o -fstype ext3 -o -fstype jfs -o -fstype xfs \) -prune -o -print
      3955 Segmentation fault      | ${RESTORECON} ${OUTFILES} ${FORCEFLAG} $*
-f - 2>&1 >> $LOGFILE

Since pid 3954 is getting the Broken pipe, and 3955 is segfaulting, I assume the
segfault is in restorecon. The line that causes the segfault is:

restorecon -p -f -

The input file list appears normal.

Comment 1 Jeremy Katz 2007-04-18 23:49:28 UTC
Dan fixed this earlier today and already got me to tag it 

Comment 2 Daniel Walsh 2007-04-19 02:41:50 UTC
Fixed in policycoreutils-2.0.9-8.fc7

Comment 3 Will Woods 2007-04-19 18:52:54 UTC
Works for me.


Note You need to log in before you can comment on or make changes to this bug.