Bug 237077 - [RHEL 5] pygtk2 bug in 2.10.1 (fixed in 2.10.3) causes Revelation to crash
[RHEL 5] pygtk2 bug in 2.10.1 (fixed in 2.10.3) causes Revelation to crash
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pygtk2 (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
http://mail.codepoet.no/archives/reve...
: Reopened
Depends On:
Blocks: 242652
  Show dependency treegraph
 
Reported: 2007-04-19 07:08 EDT by Dag Wieers
Modified: 2013-04-12 15:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0079
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 08:59:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for pygtk2-2.10.1 that backports the relevant code from pytk2-2.10.2. (4.04 KB, patch)
2007-09-29 22:33 EDT, Dag Wieers
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 347273 None None None Never

  None (edit)
Description Dag Wieers 2007-04-19 07:08:34 EDT
Description of problem:
A known problem with the pygtk2 release from RHEL5 causes GTK programs (like
Revelation) to fail.

The Revelation author references the bug in a thread about the problem.

    http://mail.codepoet.no/archives/revelation-list/2007-March/000362.html
    http://svn.codepoet.no/revelation/ticket/180
    http://www.daa.com.au/pipermail/pygtk/2006-October/012926.html

Version-Release number of selected component (if applicable):
gtk2-2.10.4-16.el5
pygtk2-2.10.1-8.el5

How reproducible:
Everytime

Steps to Reproduce:
1. Run Revelation
2.
3.
  
Actual results:
Crashes

Expected results:
Works

Additional info:
Comment 1 Matthew Barnes 2007-04-19 13:44:37 EDT
Hmm, the pygtk-2.10.3 announcement claims the crasher was introduced in 2.10.2.
 This bug is filed against 2.10.1.

In any case, it shouldn't be too hard to backport subsequent pygtk fixes.
Comment 2 RHEL Product and Program Management 2007-06-05 16:31:01 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 3 Dag Wieers 2007-06-26 04:22:49 EDT
I have no idea what Red Hat Product Management is trying to say here.

Bugs in pygtk2 (a RHEL component) are not considered for exactly what reason ?

(Matthew: yes, apparently the ChangeLog does not correctly reflect the version
that introduced the problem.)
Comment 4 Matthew Barnes 2007-06-26 08:45:25 EDT
This is just Red Hat's horrible policy of closing bugs that aren't going to make
it into the next RHEL update.  It just means that we've taken on all the bugs we
can handle for 5.1, and this one will have to wait until a subsequent update.

Resetting flags and proposing this for 5.2.
Comment 5 Dag Wieers 2007-09-25 04:51:13 EDT
[Just a quarterly reminder that this bug needs fixing.]

Can we expect an update in bugzilla when someone comes around and looks at it ?
Or is it possible that somehow without any progress in this bugreport, 5.2 comes
out with a fix ?

I'm just asking because I fear 5.2 will not fix this bug if something isn't
happening here. Would a fix show up in fastrack regardless of this report ?
Comment 6 Matthew Barnes 2007-09-26 15:14:32 EDT
I'll make sure it gets fixed for 5.2, assuming Product Management approves it.
I think they're still pretty focused on 5.1 at the moment.  This time next month
we should start to see some action.
Comment 7 Dag Wieers 2007-09-29 22:33:44 EDT
Created attachment 211551 [details]
Patch for pygtk2-2.10.1 that backports the relevant code from pytk2-2.10.2.

This patch backports the relevant bits from pygtk2 2.10.2 to 2.10.1.
The resulting packages for RHEL5 will e available from:

    http://dag.wieers.com/rpm/packages/pygtk2/

until it gets fixed upstream.
Comment 11 Matthew Barnes 2007-12-17 13:46:11 EST
Found the corresponding upstream bug for this:
http://bugzilla.gnome.org/show_bug.cgi?id=347273
Comment 12 Matthew Barnes 2007-12-17 13:54:45 EST
Fixed in pygtk2-2.10.1-9.el5
Comment 15 errata-xmlrpc 2008-01-23 08:59:42 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0079.html

Note You need to log in before you can comment on or make changes to this bug.