Bug 237106 - Exchange-based message shows up as raw html
Exchange-based message shows up as raw html
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-19 09:38 EDT by Erik Iverson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-20 02:25:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bad Message headers and body. (8.26 KB, application/octet-stream)
2007-04-19 09:38 EDT, Erik Iverson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 431582 None None None Never

  None (edit)
Description Erik Iverson 2007-04-19 09:38:31 EDT
Description of problem:
When accessing a message on an Exchange server via evolution-connector, I
occasionally get a long piece of html garbage, which doesn't render, and deep
inside says that my Outlook Web Access session has timed out.  This can happen
with an old message (that is, I've read the message successfully before in
evolution) or a new one.  Once it has happened, the message has never correctly
rendered again.  If I log on to OWA directly, I can easily see the (correctly)
rendered message, so it's still there on the Exchange server.  If I forward the
message back to myself using OWA, it again renders correctly on both OWA and in
Evolution.  

I suspect that there's some sort of time-out happening, such that non-initial
password requests from OWA aren't answered quickly enough, and that the
occasional message just doesn't make it.  But then when evolution does
reauthenticate, the error page is already cached, and Evolution doesn't
re-acquire the message from the exchange server.  

Evolution is currently set to check for password expiration every 7 minutes;
I've reduced that to 5, and I'll see if that helps.  

I've attached a saved version of one such bad message.  You'll note that it has
the headers of an email message.

Version-Release number of selected component (if applicable):


How reproducible:

It happens fairly rarely, less than 1% of messages.  I can't control the
occurance, and have not yet found anything that influences the frequency.

Steps to Reproduce:
1.  Use evolution/evolution-connector for a long time.
2.  
3.
  
Actual results:

Message displayed with correct headers, but funky non-rendering html body
indicating OWA timeout.  Message never is restored. 

Expected results:

I would expect the message to be correctly rendered, but if not, I'd expect it 
to be possible to "redownload" the message.

Additional info:

I know this one's going to be a bear to track down.  Intermittent things are
just a pain.  But I wanted to let you know about it.  I suspect that shorting
the password expiration check may reduce the frequency of the problem to
effectively zero, which seems a reasonable solution.
Comment 1 Erik Iverson 2007-04-19 09:38:31 EDT
Created attachment 153004 [details]
Bad Message headers and body.
Comment 2 Erik Iverson 2007-04-19 09:40:47 EDT
p.s.  I'm using evolution version 2.8.3-1, but have observed the same bug in
2.8.3-2, and have seen it as far back as whatever was present in FC3.

Comment 3 Matthew Barnes 2007-04-20 02:25:40 EDT
Thanks for reporting this.  My guess is the message is getting cached locally,
and you'd probably have to blow away your entire local cache
(~/.evolution/cache/http, I think) in order to force Evolution to download the
message again.

I'm going to move this upstream because I don't think I'll be able to resolve
the issue in a timely manner.  Please refer to [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=431582

Note You need to log in before you can comment on or make changes to this bug.