Bug 237117 - Evo always uses first SMTP server in label
Evo always uses first SMTP server in label
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-19 10:47 EDT by Andreas-Johann Ulvestad
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-20 01:45:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screendump (21.39 KB, image/png)
2007-04-19 10:47 EDT, Andreas-Johann Ulvestad
no flags Details

  None (edit)
Description Andreas-Johann Ulvestad 2007-04-19 10:47:56 EDT
Description of problem:
When having several accounts, Evolution always appears to use the first defined
(or primary?) account. The first account I have defined has outgoing server
'smtp.tg07.gathering.org', but I never use that one (since TG07 is an event and
long ago closed). However, always when sending e-mail, it lies and says it's
using smtp.tg07.gathering.org, whilst actually using the server I've chosen!

Version-Release number of selected component (if applicable):
evolution-2.10.1-4.fc7

How reproducible:
Always

Steps to Reproduce:
1. Define a primary/first account. Set outgoing SMTP server.
2. Define a new account, set another outgoing SMTP server.
3. Send an e-mail, choose account no 2. See, Evolution says it's using the first
SMTP server. Lies, lies!
  
Actual results:
Mail sends OK, just cosmetic.

Expected results:
It should show the actual SMTP server :-)

Additional info:
Comment 1 Andreas-Johann Ulvestad 2007-04-19 10:47:56 EDT
Created attachment 153010 [details]
screendump
Comment 2 Matthew Barnes 2007-04-20 01:45:00 EDT
Evolution shows the SMTP server of your default account, not necessarily the
account that you're sending email from (I guess since you could have messages in
the Outboxes of several accounts at once).  You can change your default account
in the "Evolution Preferences" dialog (Edit -> Preferences).

Whether the UI should be altered in some way is a question for the upstream
maintainers to address.  If you still feel it's an issue, I suggest filing a bug
report at http://bugzilla.gnome.org/ and provide some suggestions on how you
think the "Send & Receive Mail" dialog could be improved.

Note You need to log in before you can comment on or make changes to this bug.