Bug 237140 - Jasper Script Cannot Build Classpath
Summary: Jasper Script Cannot Build Classpath
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tomcat5   
(Show other bugs)
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Vivek Lakshmanan
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-19 17:12 UTC by Steve Hindmarch
Modified: 2008-01-05 13:35 UTC (History)
0 users

Fixed In Version: 5.5.25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-05 13:35:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Hindmarch 2007-04-19 17:12:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Description of problem:
I am using Jasper on Fedora Core 6 to precompile some of my jsp's.

I come across the following classpath builder errors when trying run
the jasper script:-

$ /usr/bin/jasper5.sh
/usr/bin/build-classpath: error: Could not find jasper-compiler Java extension for this JVM
/usr/bin/build-classpath: error: Could not find jasper-runtime Java extension for this JVM
/usr/bin/build-classpath: error: Could not find jsp-2.0-api Java extension for this JVM
/usr/bin/build-classpath: error: Could not find servlet-2.4-api Java extension for this JVM
/usr/bin/build-classpath: error: Some specified jars were not found
Usage: /usr/bin/jasper5.sh ( jspc )
Commands:
  jspc - Run the offline JSP compiler

The script /usr/bin/jasper5.sh tries to build a classpath using the build-classpath utility including the following: "jasper-compiler", "jasper-runtime", "jsp-2.0-api" and "servlet-2.4-api".

Jars by this name do not exist, but similarly named ones are in /usr/share/java.


By creating links to the following files I get rid of the errors

$ su -
# cd /usr/share/java
# ln -s jasper5-compiler.jar jasper-compiler.jar
# ln -s jasper5-runtime.jar jasper-runtime.jar
# ln -s tomcat5-jsp-2.0-api.jar jsp-2.0-api.jar
# ln -s tomcat5-servlet-2.4-api.jar servlet-2.4-api.jar
# exit
$ /usr/bin/jasper5.sh
Usage: /usr/bin/jasper5.sh ( jspc )
Commands:
  jspc - Run the offline JSP compiler

Either the jasper package should create these links or the names of the required jars should be changed in the script.




Version-Release number of selected component (if applicable):
tomcat5-jasper-5.5.17-6jpp.2

How reproducible:
Always


Steps to Reproduce:
1. /usr/bin/jasper5.sh

Actual Results:
See above

Expected Results:
Should see usage warning without error messages

$ /usr/bin/jasper5.sh
Usage: /usr/bin/jasper5.sh ( jspc )
Commands:
  jspc - Run the offline JSP compiler

Additional info:
The packages that install the required libraries are

tomcat5-servlet-2.4-api-5.5.17-6jpp.2
tomcat5-jsp-2.0-api-5.5.17-6jpp.2
tomcat5-jasper-5.5.17-6jpp.2

Comment 1 Vivek Lakshmanan 2007-04-20 17:43:32 UTC
Thanks for the info. This seems to be a long standing bug and seems to exist in
current versions of jpackage rpms as well (5.5.23 for instance), see
https://www.jpackage.org/bugzilla/show_bug.cgi?id=261
I will make the necessary changes to the FC6 package based on what is decided on
the above bug at JPP.

Comment 2 Devrim GUNDUZ 2008-01-05 13:35:09 UTC
This is fixed in the current releases. Closing.


Note You need to log in before you can comment on or make changes to this bug.