Bug 237141 - crash in impress on 'new presentation'
crash in impress on 'new presentation'
Status: CLOSED DUPLICATE of bug 236773
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-19 13:14 EDT by Jack Tanner
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 13:25:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Tanner 2007-04-19 13:14:16 EDT
This is a reproducible crash from Impress. Details in addition to the report
below: I was viewing a PPT file that was opened from Evolution (attachment), and
I clicked on the dropdown on the toolbar to create a 'new... presentation'.
Also, I'm using the 2.6.18-1.2798.fc6 kernel with the binary nvidia driver.

I'll try to reproduce with another PPT.

(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.1-51.fc6-i386
(V)    kernel is: Linux 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006
i686 athlon i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-5.5.21-i386
(VII)  depth of root window:    24 planes
(VIII) accessibility is: false
(VIV)  fedora release is: Fedora Core release 6 (Zod)
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
0x00429095: 0x001c0374: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x23095
0x00429dfb: 0x001c0374: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x23dfb
0x006d1420: 0x00000000:  + 0x420 (__kernel_sigreturn + 0x0)
0x008df7a3: 0x0006fb74:
/usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x267a3
(cppu::WeakImplHelper_query(com::sun::star::uno::Type const&, cppu::class_data*,
void*, cppu::OWeakObject*) + 0x153)
0x02de6348: 0x003f47f0: /usr/lib/openoffice.org2.0/program/libxo680li.so + 0x217348
0x04f00342: 0x00502520: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x27d342
0x04f25b85: 0x00502520: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2a2b85
0x04f2660e: 0x00502520: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2a360e
0x04eac564: 0x00502520: /usr/lib/openoffice.org2.0/program/libsd680li.so +
0x229564 (FadeEffectLB::Fill() + 0x94)
0x0457ef3b: 0x00071c0c: /usr/lib/openoffice.org2.0/program/libsdui680li.so + 0x34f3b
0x0458022d: 0x00071c0c: /usr/lib/openoffice.org2.0/program/libsdui680li.so + 0x3622d
0x0456b566: 0x00071c0c: /usr/lib/openoffice.org2.0/program/libsdui680li.so + 0x21566
0x04e413df: 0x00502520: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x1be3df
0x04e42aa6: 0x00502520: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x1bfaa6
0x04e3ee54: 0x00502520: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x1bbe54
0x022ab465: 0x003fbcb8: /usr/lib/openoffice.org2.0/program/libsfx680li.so +
0x2ab465 (SfxShell::ExecuteSlot(SfxRequest&, SfxInterface const*) + 0x65)
0x04fd21bb: 0x00502520: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x34f1bb
0x03dea561: 0x002dbb84: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe7561
0x020dac8f: 0x003fbcb8: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xdac8f
0x020ca1c8: 0x003fbcb8: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xca1c8
0x022ab465: 0x003fbcb8: /usr/lib/openoffice.org2.0/program/libsfx680li.so +
0x2ab465 (SfxShell::ExecuteSlot(SfxRequest&, SfxInterface const*) + 0x65)
0x02256795: 0x003fbcb8: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x256795
0x03ea2f86: 0x002dbb84: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x19ff86
0x03ea4b9a: 0x002dbb84: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x1a1b9a
0x03d4dd3c: 0x002dbb84: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x4ad3c
0x03d4db50: 0x002dbb84: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x4ab50
0x022dd4a8: 0x003fbcb8: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x2dd4a8
0x07683f96: 0x003670bc: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x288f96
0x00686351: 0x0006d6b0:
/usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x50351
(SalDisplay::DispatchInternalEvent() + 0xb1)
0x005fc3f6: 0x00043b6c:
/usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x103f6
0x005fc431: 0x00043b6c:
/usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x10431
0x00c346e1: 0x0009d0bc: /lib/libglib-2.0.so.0 + 0x296e1
0x00c36442: 0x0009d0bc: /lib/libglib-2.0.so.0 + 0x2b442 (g_main_context_dispatch
+ 0x182)
0x00c3941f: 0x0009d0bc: /lib/libglib-2.0.so.0 + 0x2e41f
0x00c39985: 0x0009d0bc: /lib/libglib-2.0.so.0 + 0x2e985
(g_main_context_iteration + 0x65)
0x005fe321: 0x00043b6c:
/usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x12321
0x006877c7: 0x0006d6b0:
/usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x517c7
(X11SalInstance::Yield(bool, bool) + 0x37)
0x07497598: 0x003670bc: /usr/lib/openoffice.org2.0/program/libvcl680li.so +
0x9c598 (Application::Yield(bool) + 0x68)
0x0749766c: 0x003670bc: /usr/lib/openoffice.org2.0/program/libvcl680li.so +
0x9c66c (Application::Execute() + 0x3c)
0x07fc5979: 0x00058dec: /usr/lib/openoffice.org2.0/program/libsoffice.so +
0x27979 (desktop::Desktop::Main() + 0x1779)
0x0749d16c: 0x003670bc: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xa216c
0x0749d275: 0x003670bc: /usr/lib/openoffice.org2.0/program/libvcl680li.so +
0xa2275 (SVMain() + 0x35)
0x07fb7079: 0x00058dec: /usr/lib/openoffice.org2.0/program/libsoffice.so +
0x19079 (sal_main + 0x59)
0x07fb7104: 0x00058dec: /usr/lib/openoffice.org2.0/program/libsoffice.so +
0x19104 (main + 0x44)
0x4d01cf2c: 0x00138d9c: /lib/libc.so.6 + 0x15f2c (__libc_start_main + 0xdc)
0x080484a1: 0x00000618: /usr/lib/openoffice.org2.0/program/simpress.bin + 0x4a1
...end stackreport details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0x00fa9000)
	libuno_sal.so.3 => /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 (0x006c8000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org2.0/program/libuno_salhelpergcc3.so.3 (0x004be000)
	libstore.so.3 => /usr/lib/openoffice.org2.0/program/libstore.so.3 (0x009fb000)
	libdl.so.2 => /lib/libdl.so.2 (0x003bd000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x00110000)
	libstlport_gcc.so => /usr/lib/openoffice.org2.0/program/libstlport_gcc.so
(0x00bd8000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00127000)
	libm.so.6 => /lib/libm.so.6 (0x0094e000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00bc5000)
	libc.so.6 => /lib/libc.so.6 (0x004c3000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x00212000)
	/lib/ld-linux.so.2 (0x4cfea000)
...end sample ldd details ...
Comment 1 Caolan McNamara 2007-04-19 13:25:45 EDT

*** This bug has been marked as a duplicate of 236773 ***
Comment 2 Jack Tanner 2007-04-19 13:48:04 EDT
Sorry about the dupe; confirming that it's fixed in 2.0.4-5.5.22.

Note You need to log in before you can comment on or make changes to this bug.