Bug 237157 - sendmail-devel doesn't require sendmail
sendmail-devel doesn't require sendmail
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sendmail (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
: EasyFix, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-19 14:37 EDT by Robert Scheck
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 07:38:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fedora-4-epel/31617-mimedefang-2.62-1.el4/ppc/build.log (4.92 KB, text/plain)
2007-04-19 14:38 EDT, Robert Scheck
no flags Details
fedora-4-epel/31617-mimedefang-2.62-1.el4/ppc/root.log (24.52 KB, text/plain)
2007-04-19 14:39 EDT, Robert Scheck
no flags Details

  None (edit)
Description Robert Scheck 2007-04-19 14:37:11 EDT
Description of problem:
The package sendmail-devel doesn't depend on sendmail, but at RHEL5, Fedora 
Core 5, 6 and Rawhide it does. Please fix this inconsistent behaviour soon.

For further information see the build log of mimedefang.

Version-Release number of selected component (if applicable):
sendmail-devel-8.13.1-3.RHEL4.5

How reproducible:
Everytime.

Actual results:
sendmail-devel doesn't require sendmail

Expected results:
sendmail-devel depends on sendmail

Additional info:
[12:00:22] < rsc> http://buildsys.fedoraproject.org/logs/fedora-4-epel/31617-
mimedefang-2.62-1.el4/ppc/job.log - somebody an idea. The mimedefang package 
has buildrequires sendmail-devel
[12:06:47] < Kick_> rsc:  sendmail-devel from RHEL4 doesn't require sendmail
[12:08:07] < rsc> Kick_: why? That sounds broken
[12:09:28] < rsc> *very broken*
[12:10:21] < G> of course it does ;)
[12:11:46] < G> on the total off chance, there isn't a sponsor hanging about is 
there?
[12:12:22] < Kick_> rsc:  I have no idea, but I've checked it and it hasn't the 
requirement. (It has been added in F7, though)
[12:12:51] < G> then again, what does sendmail-devel include?
[12:13:13] < Kick_> G: the requirements ?
[12:13:17] < G> sendmail these days is just a static link to 'something better' 
like postfix no?
[12:13:32] < Kick_> $ rpm -qp --requires  sendmail-devel-8.13.1-
3.RHEL4.5.ppc.rpm
[12:13:32] < Kick_> rpmlib(CompressedFileNames) <= 3.0.4-1
[12:13:32] < Kick_> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
[12:13:42] < G> oh right, I get, you, sendmail-devel requires stuff like 
postfix-devel?
[12:14:06] < Kick_> no
[12:14:07] < G> (or is meant to)
[12:17:02] < rsc> Kick_: Fix it :)
[12:17:28] < rsc> Kick_: are you commiting the fix already to your internal CVS 
or should I open a bug report? ;)
[12:17:46] < Kick_> rsc:  not my package ;-)  And getting fixes into RHEL is a 
lengthy process
[12:17:55] < Kick_> rsc:  please bugzilla
[12:19:53] < rsc> Kick_: lengthy process? Just give me access to the CVS ;)
[12:23:33] < Kick_> rsc:  I just went to the next room where the sendmail 
maintainer sits ;-)   Thomas is looking into it, but mentioned that nothing of 
sendmail-devel actually requires anything from sendmail as there are p.e. no 
shared libs
[12:24:07] < Kick_> ... but this doesn't answer why he added the  dep in Fedora
[12:29:07] < rsc> Kick_: exactly.
Comment 1 Robert Scheck 2007-04-19 14:38:26 EDT
Created attachment 153043 [details]
fedora-4-epel/31617-mimedefang-2.62-1.el4/ppc/build.log
Comment 2 Robert Scheck 2007-04-19 14:39:05 EDT
Created attachment 153044 [details]
fedora-4-epel/31617-mimedefang-2.62-1.el4/ppc/root.log
Comment 3 Robert Scheck 2007-04-28 10:52:37 EDT
Thomas, ping?
Comment 4 Thomas Woerner 2007-04-30 07:27:21 EDT
sendmail-devel has no dependency on sendmail, because there are no shared
libraries in the sendmail and sendmail-devel package.

sendmail-cf, sendmail-devel and sendmail-doc has got the dependency in FC-4, to
be consistent to other sub-packages.
Comment 5 Robert Scheck 2007-04-30 07:32:27 EDT
Well Thomas...either adding the dependency from -devel to the base package
at sendmail everywhere or nowhere, this has to be consistent; everything else 
would be just blahfoo.
Comment 6 Thomas Woerner 2007-04-30 07:34:52 EDT
Do you really want me to kick it out again for FC-4+ and RHEL-5+?
Comment 7 Robert Scheck 2007-05-07 16:12:37 EDT
Do what you want. My mimedefang package now depends at any branch on sendmail 
and sendmail-devel to work around such crazy Red Hat things (just to be sure 
that it works when you're dropping the requirement from FC-4+ and RHEL-5+) ;-)
Comment 8 Thomas Woerner 2007-07-25 07:38:42 EDT
The requirements will be there from now on. Closing as NOT A BUG.

Note You need to log in before you can comment on or make changes to this bug.