Bug 237158 - Cannot drag an application window to another workspace if a modal dialog is active
Summary: Cannot drag an application window to another workspace if a modal dialog is a...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: metacity
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-19 18:40 UTC by John Walicki
Modified: 2010-03-30 08:25 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-03-30 08:25:40 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0245 normal SHIPPED_LIVE metacity bug fix and enhancement update 2010-03-29 12:44:04 UTC

Description John Walicki 2007-04-19 18:40:11 UTC
Description of problem:
Cannot drag an application window to another workspace if a modal dialog is active.

Version-Release number of selected component (if applicable):
metacity-2.16.0-8.el5

How reproducible:
Always

Steps to Reproduce:
1. Open a modal dialog from Mozilla( or other applications, e.g. IBM product),
from the task bar
2. try to drag Mozilla to a second virtual desktop. 

Actual results:
You'll find that only the modal dialog is moved to the target desktop but the
background window remains unchanged.

Expected results:


Additional info:

Comment 2 RHEL Product and Program Management 2007-06-06 18:06:42 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.

Comment 3 John Walicki 2007-06-06 20:18:51 UTC
This drag/drop behavior of the modal dialog box and application is not the
expected user experience.  The user would expect that the application (and its
modal dialog box) should be moved to the target desktop.

Please consider this for a future release.

Comment 4 Owen Taylor 2009-10-19 22:59:33 UTC
This is still occurring with current upstream Metacity (2.28). I tracked down the problem and filed a bug upstream with a fix:

 https://bugzilla.gnome.org/show_bug.cgi?id=598995

Comment 6 John Walicki 2009-10-20 00:41:57 UTC
Owen - Wow! I forgot all about this bug.  Many thanks for fixing it.   I think the Lotus team will be happy to hear about the fix too.  I don't remember the specific use case that was driving me crazy.

Let's get the patch committed upstream.   Backporting it to RHEL 5 would be nice but considering its been broken so long, it might be good enough to finally fix it in RHEL6.

Thanks!

Comment 7 Owen Taylor 2009-11-11 20:55:00 UTC
Fix will be in RHEL-6 and hopefully upstream - Metacity is a bit quiet for development at the moment, but I'll definitely include it in Mutter which is taking over from Metacity for GNOME 3. 

But since we're updating metacity for RHEL 5.5, we'll include the fix there as well.

built in dist-5E-qu-candidate as metacity-2.16.0-15.el5

Comment 11 errata-xmlrpc 2010-03-30 08:25:40 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0245.html


Note You need to log in before you can comment on or make changes to this bug.