Bug 237166 - NameError: global name 'socket' is not defined
NameError: global name 'socket' is not defined
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-19 15:19 EDT by James Laska
Modified: 2013-09-02 02:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 15:28:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2007-04-19 15:19:51 EDT
# TREE f7-test4-20070418.0
# ARCH ppc (IBM power5)
# RPM anaconda-11.2.0.51-1.ppc

Attempting to install using VNC fails due to missing/incorrect python import?

Running anaconda, the Fedora system installer - please wait...
Probing for video card:   Unable to probe
No video hardware found, assuming headless
Starting VNC...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 838, in <module>
    runVNC(vncpassword, vncconnecthost, vncconnectport, doStartupX11Actions)
  File "/usr/bin/anaconda", line 379, in runVNC
    vncStartedCB=vncStartedCB)
  File "/usr/lib/anaconda/vnc.py", line 229, in startVNCServer
    except socket.error:
NameError: global name 'socket' is not defined
install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /mnt/source done
        /selinux done
you may safely reboot your system
Comment 1 David Cantrell 2007-04-19 15:28:07 EDT
Fixed in rawhide (anaconda-11.2.0.52).

Note You need to log in before you can comment on or make changes to this bug.