Bug 237168 - yum backtrace with debuginfo repo
yum backtrace with debuginfo repo
Status: CLOSED DUPLICATE of bug 230851
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-19 15:47 EDT by Sertaç Ö. Yıldız
Modified: 2014-01-21 17:57 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 16:51:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sertaç Ö. Yıldız 2007-04-19 15:47:37 EDT
yum-metadata-parser-1.0.4-1.fc7
yum-3.1.6-2.fc7


$ sudo yum  --disablerepo \* --enablerepo development-debuginfo check-update 
Loading "installonlyn" plugin
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 94, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 263, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 317, in doCommand
    ypl = base.returnPkgLists(extcmds)
  File "/usr/share/yum-cli/cli.py", line 769, in returnPkgLists
    ypl = self.doPackageLists(pkgnarrow=pkgnarrow)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 1049, in
doPackageLists
    for (n,a,e,v,r) in self.up.getUpdatesList():
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 506, in <lambda>
    up = property(fget=lambda self: self._getUpdates(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 407, in _getUpdates
    self.pkgSack.simplePkgList())
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 493, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 376, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 200, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 132, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 189, in
_check_db_version
    if repo.repoXML.repoData.has_key(mdtype):
AttributeError: 'NoneType' object has no attribute 'repoData'

repository configuration:
[development-debuginfo]
name=Fedora Core - Development - Debug
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/development/$basearch/debug/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide-debug&arch=$basearch
enabled=0
gpgcheck=0
Comment 1 Jeremy Katz 2007-04-19 16:51:34 EDT

*** This bug has been marked as a duplicate of 230851 ***
Comment 2 Sertaç Ö. Yıldız 2007-04-19 16:58:53 EDT
it also happens _without_ "disablerepo". might there be a problem with
"enablerepo" too?

$ sudo yum --enablerepo development-debuginfo check-update 
Loading "installonlyn" plugin
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 94, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 263, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 317, in doCommand
    ypl = base.returnPkgLists(extcmds)
  File "/usr/share/yum-cli/cli.py", line 769, in returnPkgLists
    ypl = self.doPackageLists(pkgnarrow=pkgnarrow)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 1049, in
doPackageLists
    for (n,a,e,v,r) in self.up.getUpdatesList():
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 506, in <lambda>
    up = property(fget=lambda self: self._getUpdates(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 407, in _getUpdates
    self.pkgSack.simplePkgList())
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 493, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 376, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 200, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 132, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 189, in
_check_db_version
    if repo.repoXML.repoData.has_key(mdtype):
AttributeError: 'NoneType' object has no attribute 'repoData'
Comment 3 Jeremy Katz 2007-04-19 17:15:15 EDT
Yes.  --enablerepo and --disablerepo seem to have some lingering bad behavior.

Note You need to log in before you can comment on or make changes to this bug.