Bug 237169 - Xvdieo does not work on intel driver
Xvdieo does not work on intel driver
Status: CLOSED DUPLICATE of bug 239125
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Depends On:
  Show dependency treegraph
Reported: 2007-04-19 16:00 EDT by Ralf Ertzinger
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-27 21:19:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
xorg config (807 bytes, text/plain)
2007-04-19 16:00 EDT, Ralf Ertzinger
no flags Details
Xorg.0.log (93.11 KB, text/plain)
2007-04-19 16:02 EDT, Ralf Ertzinger
no flags Details
xvinfo output (4.19 KB, text/plain)
2007-04-30 17:11 EDT, Ralf Ertzinger
no flags Details

  None (edit)
Description Ralf Ertzinger 2007-04-19 16:00:57 EDT
Description of problem:
When using the intel driver on a 945GM, Xvideo does not work (Xv*Put* calls
return BadAlloc).

Example output from a test application:
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  140 (XVideo)
  Minor opcode of failed request:  19 ()
  Serial number of failed request:  231
  Current serial number in output stream:  232

Xorg.log and xorg.conf attached.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start program using XVideo
Actual results:
XVideo operations fail.

Expected results:
Operations succeed.

Additional info:
Comment 1 Ralf Ertzinger 2007-04-19 16:00:57 EDT
Created attachment 153052 [details]
xorg config
Comment 2 Ralf Ertzinger 2007-04-19 16:02:28 EDT
Created attachment 153053 [details]
Comment 3 Will Woods 2007-04-30 14:04:29 EDT
At this time, Xv is known not to work with desktop effects enabled. As a
workaround, you can switch to the non-Xv video driver (using
gstreamer-properties) to get video to play.
Comment 4 Adam Jackson 2007-04-30 14:10:45 EDT
Can you attach the output of 'xvinfo' as well please?  It's in xorg-x11-utils if
you don't already have it installed.
Comment 5 Ralf Ertzinger 2007-04-30 17:10:28 EDT
Is this expected to change for F7? In FC6 (and for most of the F7 development)
Xv worked (although with some funny artifacts). IMVHO this was preferrable to
the current state, especially as most of the time the video window will not be
moved around/be in fullscreen mode.
Comment 6 Ralf Ertzinger 2007-04-30 17:11:03 EDT
Created attachment 153825 [details]
xvinfo output
Comment 7 Leo 2007-04-30 19:03:41 EDT
I am also experiencing a similar problem.
Comment 8 Mary Ellen Foster 2007-06-11 18:04:35 EDT
This still seems to be a problem in Fedora 7 final ...
Comment 9 Juan Pablo Salazar Bertin 2007-08-15 19:35:58 EDT
This is a duplicate of bug #239125, which is newer but has more info about the
bug filed upstream.
Comment 10 Dave Airlie 2007-10-27 21:19:12 EDT

*** This bug has been marked as a duplicate of 239125 ***

Note You need to log in before you can comment on or make changes to this bug.