Bug 237177 - Emacs segfaults when invoked as 'emacs -q'
Emacs segfaults when invoked as 'emacs -q'
Status: CLOSED DUPLICATE of bug 239344
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Coldwell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-19 16:52 EDT by Khem Raj
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-21 11:20:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core file (1.73 MB, application/x-bzip)
2007-04-20 18:01 EDT, Khem Raj
no flags Details

  None (edit)
Description Khem Raj 2007-04-19 16:52:29 EDT
Description of problem:

I tried to start emacs from my shell 'emacs -q' command and also with simple
emacs command. In both cases it segfaulted.

Version-Release number of selected component (if applicable):
emacs-22.0.95-1.fc7

How reproducible:


Steps to Reproduce:
1. Install FC7 Test3 and yum update it to very latest.
2. Install emacs
3. Run 'emacs' or 'emacs -q'
  
Actual results:
Fatal error (11)Segmentation fault


Expected results:
I expected it to launch emacs editor

Additional info:

I dumped the core and gdb'ed it

Program terminated with signal 11, Segmentation fault.
#0  0x00c90402 in __kernel_vsyscall ()
(gdb) bt
#0  0x00c90402 in __kernel_vsyscall ()
#1  0x06eb6366 in ?? ()
#2  0x080f40ff in ?? ()
#3  0x00006ae5 in ?? ()
#4  0x0000000b in ?? ()
#5  0x00000000 in ?? ()
(gdb)
Comment 1 Chip Coldwell 2007-04-20 11:05:33 EDT
(In reply to comment #0)
> 
> I dumped the core and gdb'ed it

Can you put the core somewhere where I can get it?

Chip
Comment 2 Khem Raj 2007-04-20 18:01:40 EDT
Created attachment 153220 [details]
core file

here is compressed core file.
Comment 3 Chip Coldwell 2007-04-23 15:19:17 EDT
It looks like emacs is catching a signal before the auto-save-list-file-name has
been initialized, and that is causing the segfault.  A more interesting question
is why is emacs getting a signal when you start with the "-q" switch.

Could you run this and post the output to this bug?

strace -e trace=exit_group -e signal=\!sigio emacs -q

Comment 4 Khem Raj 2007-04-23 16:46:00 EDT
here it comes.

strace -e trace=exit_group -e signal=\!sigio emacs -q
--- SIGCHLD (Child exited) @ 0 (0) ---
--- SIGCHLD (Child exited) @ 0 (0) ---
--- SIGCHLD (Child exited) @ 0 (0) ---
--- SIGCHLD (Child exited) @ 0 (0) ---
--- SIGCHLD (Child exited) @ 0 (0) ---

(emacs:20950): 4-CRITICAL **: 4: assertion `\xff\xff\xff\xff' failed
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Process 20950 detached
Comment 5 Chip Coldwell 2007-05-07 10:59:54 EDT
Could you try turning off SELinux and see if the bug reproduces?

Chip
Comment 6 Khem Raj 2007-05-07 14:20:18 EDT
(In reply to comment #5)
> Could you try turning off SELinux and see if the bug reproduces?
> 
> Chip
> 

yes SELinux is turned off. My machine is a Core 2 duo machine(64 bit) running 
32-bit Fedora
Comment 7 Chip Coldwell 2007-05-13 09:31:18 EDT
I think this is very likely a duplicate of bug 239344; could you report your
glibc version, please?
Comment 8 Khem Raj 2007-05-14 15:15:04 EDT
(In reply to comment #7)
> I think this is very likely a duplicate of bug 239344; could you report your
> glibc version, please?

glibc-2.5.90-22, which I think is latest. I just reinstalled emacs rpms and 
gave it another try but I got segfault

Fatal error (11)Segmentation fault


Comment 9 Chip Coldwell 2007-05-16 09:25:12 EDT
Could you try downgrading to glibc-2.5.90-21 and see if the problem goes away?
Comment 10 Chip Coldwell 2007-05-21 11:20:49 EDT

*** This bug has been marked as a duplicate of 239344 ***

Note You need to log in before you can comment on or make changes to this bug.