Bug 237189 - libpri-1.4.0-3.fc7.src.rpm fails to build as non-root, pathissue on restorecon
Summary: libpri-1.4.0-3.fc7.src.rpm fails to build as non-root, pathissue on restorecon
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libpri (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-19 22:00 UTC by R P Herrold
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-19 05:35:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description R P Herrold 2007-04-19 22:00:52 UTC
libpri-1.4.0-3.fc7.src.rpm fails to build as non-root, as the path to restorecon
is not in an end user's path

$ rpm -qf /sbin/restorecon
policycoreutils

---------------------------------

please either munge the build path, or add the /sbin/ to restorecon in the .spec
file

Comment 1 R P Herrold 2007-04-19 22:01:33 UTC
scrape from the end of a build:

install -m 755 libpri.so.1.0 /var/tmp/libpri-1.4.0-root-herrold/usr/lib
if [ -x /usr/sbin/sestatus ] && ( /usr/sbin/sestatus | grep "SELinux status:"
|grep -q "enabled"); then  restorecon -v
/var/tmp/libpri-1.4.0-root-herrold/usr/lib/libpri.so.1.0; fi
/bin/sh: restorecon: command not found
make: *** [install] Error 127
error: Bad exit status from /var/tmp/rpm-tmp.22370 (%install)



Comment 2 R P Herrold 2007-04-19 22:04:32 UTC
workaround proof of issue:

$ cat ./wrap-libpri.sh
#!/bin/sh
#
#
export
PATH=/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/sbin:/usr/sbin
rpmbuild --rebuild libpri-1.4.0-3.fc7.src.rpm
#

...

Wrote: /home/herrold/rpmbuild/RPMS/i386/libpri-1.4.0-3.i386.rpm
Wrote: /home/herrold/rpmbuild/RPMS/i386/libpri-devel-1.4.0-3.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.81303
+ umask 022


Comment 3 Jeffrey C. Ollie 2007-11-03 03:25:06 UTC
I am unable to reproduce the problem with the current version:

http://koji.fedoraproject.org/koji/buildinfo?buildID=23261

Please give this version a try.


Note You need to log in before you can comment on or make changes to this bug.