Bug 237197 - perl-File-Slurp: EL-4, EL-5 branches?
perl-File-Slurp: EL-4, EL-5 branches?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: perl-File-Slurp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-19 18:26 EDT by Chris Weyl
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-30 14:53:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Weyl 2007-04-19 18:26:44 EDT
It would be useful to me to have this package under RHEL4 and 5.  Any chance I
can prevail upon you to build for those distros, as well?

(perl-File-Slurp's review is bug 167282.)
Comment 1 Ralf Corsepius 2007-04-20 00:06:02 EDT
(In reply to comment #0)
> It would be useful to me to have this package under RHEL4 and 5.  Any chance I
> can prevail upon you to build for those distros, as well?
> 
> (perl-File-Slurp's review is bug 167282.)

Short answer: No, I do not support EPEL.

Longer answer: I am not supporting EPEL. Primarily, because I am not using EPEL.

More generally, 

* technically, I do not feel able to support RHEL, because of the
additional technical constraints EPEL imposes (ABIs, longevity etc).
Additionally, I think, EPEL contradicts the objectives of RHEL (stability,
longevity).


* politically, 

1. I refuse to provide a non-free commercial distribution
(such as RHEL) to make it match user-demands better. 
It means nothing else but the vendor (RH) not meeting these user's demands. 
IMO, people wanting to use Fedora packages on RHEL should feel encouraged to
switching distros, e.g. to Fedora.

2. I consider Fedora EPEL to be undermining Fedora's objectives.
It causes users not to use Fedora but to pay _RH_ for their commercial
base-distro. More radically formulated: EPEL helps RH to outsource development
resources, but doesn't help Fedora.

In a nutshell: I consider EPEL to be RH's business, not the communities.


I see 3 alternatives:

1. You take over perl-File-Slurp for all of Fedora and EPEL.
2. You maintain it for EPEL and I do so for Fedora.
3. This package doesn't make it into EPEL.
Comment 2 Ralf Corsepius 2007-11-28 23:43:36 EST
Ping? 

Chris, please feel free to take over for EPEL.
Comment 3 Chris Weyl 2007-11-30 14:53:54 EST
No longer needed at $work :)

Note You need to log in before you can comment on or make changes to this bug.