Bug 237210 - Incorrect documentation on man page.
Summary: Incorrect documentation on man page.
Status: CLOSED DUPLICATE of bug 220657
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bash (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-20 03:04 UTC by Wade Mealing
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-23 10:47:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wade Mealing 2007-04-20 03:04:08 UTC
Description of problem:

Bash's ulimit -m has no effect because the kernel can not control the amount of
rss memory per process. Please update the man page to show that this option has
no effect on Linux systems.

Version-Release number of selected component (if applicable):

Any version I can find from AS2-1 to RHEL5.

How reproducible:

Every time.
Steps to Reproduce:
1. view man page.
2. search for limit, 
3. see section on -m, note that it doesn't work.
  
Actual results:

See

 -m     The maximum resident set size

Expected results:

 -m     The maximum resident set size (Has no effect on Linux systems) 


Additional info:

Jwhiter shows that the kernel or userspace applications do not adhere to this
limit in bugzilla 220657.  Upstreams bash man pages also seem to have the same
issue.

Comment 1 Tim Waugh 2007-04-23 10:47:14 UTC

*** This bug has been marked as a duplicate of 220657 ***


Note You need to log in before you can comment on or make changes to this bug.