Bug 237212 - Incorrect documentation on man page.
Incorrect documentation on man page.
Status: CLOSED DUPLICATE of bug 220657
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bash (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On: 237211
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-19 23:18 EDT by Wade Mealing
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-15 05:42:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2007-04-19 23:18:05 EDT
+++ This bug was initially created as a clone of Bug #237211 +++

Description of problem:

Bash's ulimit -m has no effect because the kernel can not control the amount of
rss memory per process. Please update the man page to show that this option has
no effect on Linux systems.

Version-Release number of selected component (if applicable):

Any version I can find from AS2-1 to RHEL5.

How reproducible:

Every time.
Steps to Reproduce:
1. view man page.
2. search for limit, 
3. see section on -m, note that it doesn't work.
  
Actual results:

See

 -m     The maximum resident set size

Expected results:

 -m     The maximum resident set size (Has no effect on Linux systems) 


Additional info:

Jwhiter shows that the kernel or userspace applications do not adhere to this
limit in bugzilla 220657.  Upstreams bash man pages also seem to have the same
issue.
Comment 1 RHEL Product and Program Management 2007-05-09 00:41:04 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Ivana Varekova 2007-05-15 04:47:47 EDT
builtins(1) is a part of bash package.
Comment 3 Tim Waugh 2007-05-15 05:42:36 EDT

*** This bug has been marked as a duplicate of 220657 ***

Note You need to log in before you can comment on or make changes to this bug.