Bug 237234 - Man page for tcsh is incorrect, tcsh can not set memory limits on linux
Summary: Man page for tcsh is incorrect, tcsh can not set memory limits on linux
Status: CLOSED DUPLICATE of bug 247637
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tcsh   
(Show other bugs)
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Vitezslav Crhonek
QA Contact: Bill Huang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-20 07:12 UTC by Wade Mealing
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-05 07:29:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wade Mealing 2007-04-20 07:12:14 UTC
Description of problem:

Tcsh man page implies that the the shell is able to set limits on the amount of
memory used by a process (for more information see BZ 220657)

Version-Release number of selected component (if applicable):

tcsh-6.13-9

How reproducible:

Every time I look at the man page.

Steps to Reproduce:
1. Consult man page for tcsh when using tcsh to set limitations on a per process
basis
2. Set limitations on the process.
3. tclsh accepts limits being set, all looks good then the process bypasses
limits set ! WIN! 
  
Actual results:

Amaze your friends as the limits do not take effect.

Expected results:

Man page to say that the limits do not apply on Linux

Additional info:

Comment 1 Vitezslav Crhonek 2007-04-23 14:36:44 UTC
Hi,

man page contains this:

"Controllable resources currently include (if supported by the OS):"

This is followed by list of resources. Isn't it enough? Some of them work (e.g.
filesize), some don't work (e.g. memoryuse) in RHEL.

Or do you think I shall try all resources and then say which aren't supported by
the OS?

Comment 2 Wade Mealing 2007-06-19 14:44:27 UTC
Vitezslav, 

I think it is worthwhile documenting what does and doesnt work if you have the
bandwidth, otherwise I guess that if supported by the OS is good enough.

Wade

Comment 4 Vitezslav Crhonek 2007-09-05 07:29:25 UTC

*** This bug has been marked as a duplicate of 247637 ***


Note You need to log in before you can comment on or make changes to this bug.