Bug 237248 - SELinux Amavisd-new/perl SpamAssassin denial
SELinux Amavisd-new/perl SpamAssassin denial
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-20 09:20 EDT by Anthony Messina
Modified: 2008-05-01 11:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 16:58:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Messina 2007-04-20 09:20:39 EDT
Description of problem:
Amavisd-new needs to be able to have perl (called from within amavis) access
SpamAssassin files /var/lib/spamassassin

Version-Release number of selected component (if applicable):
selinux-policy-2.4.6-57.fc6

How reproducible:
Every time

Steps to Reproduce:
1. Filter mail through amavisd-new with spamassassin enabled

  
Actual results:
avc: denied { search } for comm="amavisd" dev=sda2 egid=104 euid=103
exe="/usr/bin/perl" exit=-2 fsgid=104 fsuid=103 gid=104 items=0
name="spamassassin" pid=3155 scontext=system_u:system_r:amavis_t:s0 sgid=104
subj=system_u:system_r:amavis_t:s0 suid=103 tclass=dir
tcontext=system_u:object_r:spamd_var_lib_t:s0 tty=(none) uid=103

Expected results:
No denial

Additional info:
Running in permissive mode.
Comment 1 Daniel Walsh 2007-05-17 12:38:45 EDT
Fixed in selinux-policy-2.4.6-71

Note You need to log in before you can comment on or make changes to this bug.