Bug 237302 - lots of "$filename: no dev" messages when starting LiveCD
Summary: lots of "$filename: no dev" messages when starting LiveCD
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-04-20 17:52 UTC by Will Woods
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-18 21:06:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Please try this policy file to see if it fixes the problem (108 bytes, application/octet-stream)
2007-04-23 13:17 UTC, Daniel Walsh
no flags Details

Description Will Woods 2007-04-20 17:52:45 UTC
When starting the current (20070419) LiveCD, a lot of messages saying (e.g.)

/var/lib/random-seed: no dev

appear on the console after readahead starts.

Comment 1 Jeremy Katz 2007-04-20 18:53:29 UTC
Happens on regular installs too.

Comment 2 Jeremy Katz 2007-04-20 19:02:36 UTC
I've commented out the fprintf so that it's at least not as annoying, but could
use looking to see why it's happening still.  But now just a release blocker and
not a test release blocker

Comment 3 Karel Zak 2007-04-23 11:51:32 UTC
The problem is selinux. I can't reproduce it with selinux=0. The readahead needs
to read /dev/root (and others partitions where are files from readahead lists).

  open("/dev/root", O_RDONLY)             = -1 EACCES (Permission denied)

Note: the readahead runs (on FC6) with system_u:system_r:readahead_t:s0

It seems the problem is pretty old (include FC6). Now it appears, because the
new version doesn't ignore the problem and reports it to stderr.

It's important fix the problem in selinux policy, because it has terrible impact
to readahead performace -- now (with selinux) the readahead can't read
information about FS blocks.

I don't know why, but I cannot found any avc messages about this issue in system
logs.



Comment 4 Daniel Walsh 2007-04-23 13:17:02 UTC
Created attachment 153279 [details]
Please try this policy file to see if it fixes the problem

Steps to build
Extract myreadahead.te to a local file, as root execute the following
# yum install selinux-policy-devel
# make -f /usr/share/selinux/devel/Makefile
# semodule myreadahead.pp

See if readahead works better.

Comment 5 Karel Zak 2007-04-25 21:34:12 UTC
It works for me. Please, submit the change to standard system policy. Thanks.

Comment 6 Daniel Walsh 2007-04-26 00:08:45 UTC
Already in selinux-policy-2.6.1-1.fc7

Comment 7 Jeremy Katz 2007-05-18 21:06:01 UTC
This okay to me now


Note You need to log in before you can comment on or make changes to this bug.