Bug 237337 - perl-Digest-SHA -- Perl support for SHA digests
perl-Digest-SHA -- Perl support for SHA digests
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Wouters
Fedora Package Reviews List
:
Depends On:
Blocks: perl-Net-DNS-SEC
  Show dependency treegraph
 
Reported: 2007-04-20 16:39 EDT by Wes Hardaker
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-20 17:40:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pwouters: fedora‑review+
tibbs: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Wes Hardaker 2007-04-20 16:39:22 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Wes Hardaker 2007-04-20 16:40:36 EDT
Spec URL: http://www.hardakers.net/FE/perl-Digest-SHA.spec
SRPM URL: http://www.hardakers.net/FE/perl-Digest-SHA.spec
Description: Digest::SHA is a complete implementation of the NIST
Secure Hash Stan- dard.  It gives Perl programmers a convenient way to
calculate SHA-1, SHA-224, SHA-256, SHA-384, and SHA-512 message
digests.  The module can handle all types of input, including
partial-byte data.

(I don't currently have a sponsor, although there are other packages
I've submitted as well tagged as needing a sponsor as well).
Comment 2 Bernard Johnson 2007-04-30 13:13:41 EDT
Please post SRPM.
Comment 4 Wes Hardaker 2007-05-08 17:03:45 EDT
Spec URL: http://www.hardakers.net/FE/perl-Digest-SHA.spec
SRPM URL: http://www.hardakers.net/FE/perl-Digest-SHA-5.44-2.src.rpm

- Use vendorarch instead of vendorlib
Comment 5 Wes Hardaker 2007-05-14 20:38:58 EDT
Spec URL: http://www.hardakers.net/FE/perl-Digest-SHA.spec
SRPM URL: http://www.hardakers.net/FE/perl-Digest-SHA-5.44-3.src.rpm

- BuildRequire a slew of modules needed for testing/building
Comment 6 Paul Wouters 2007-05-23 16:44:20 EDT
*** Bug 226256 has been marked as a duplicate of this bug. ***
Comment 7 Paul Wouters 2007-05-24 17:04:21 EDT
(In reply to comment #6)
> *** Bug 226256 has been marked as a duplicate of this bug. ***

That was a mistake, since that was perl-Digest-SHA1, not perl-Digest-SHA. I'll
pick up the review for this though.
Comment 8 Paul Wouters 2007-05-24 18:04:30 EDT
1) description cuts word in two "Stan- dard". Can you change the formatting of that?
2) %{__perl}  needs to get OPTIMIZE="$RPM_OPT_FLAGS"
3) installed binary does not work:

# shasum /usr/bin/shasum
read() on unopened filehandle at /usr/lib/perl5/5.8.8/Digest/base.pm line 24.



OK rpmlint is clean
OK package properly named
OK licence is opensource and matches upstream, copliant with legal req.
OK license included in %doc
OK spec file uses american english and is legitable
OK upstream sources matches md5sum of source in srpm.
OK packages builds on x86_64/i385
OK BuildRequires correct, package builds in mock
OK no direct /locale/ use
OK no use of ldconfig needed
OK not relocatable
OK no duplicate files or bad permissions (rpmlint is quit)
OK files section has defattr.
OK consistent use of macros
OK clean removes buildroot
OK no large docs in package
OK doc doesnt affect runtime
OK no headers outside -devel package
OK no static libs
OK dependancies on itself
OK no libtool *.la files
OK no GUI files
OK does not own other packages' files
OK cleans buildroot before install
OK valid UTF-8

Can you see what the deal with 3) is? And fix 1) and 2)
Comment 9 Jason Tibbitts 2007-05-24 22:25:23 EDT
Just a note that cpanspec (or one of the module routines it calls) is actually
hyphenating the %description automatically, and that is indeed a proper
hyphenation of the word "standard".
Comment 10 Paul Wouters 2007-05-25 11:04:16 EDT
I guess my feeling is that hyphenationof words was obsoleted by "word wrap" on
modern computers. It's not that we're stuck typing a word halfway, realising we
ran out of space on that line and we couldn't delete the letters. 

I've grown very unaccustomed to hyphernation in the digital age, it gives me a
full reading stop for my brain to figure it out.
Comment 11 Jason Tibbitts 2007-05-26 17:20:03 EDT
I can't say that I disagree, my point was only that you'll probably see it in
many cpanspec-generated specfiles.  Of course, the packager is free to reformat
the %description text as they wish, including removing such hyphenation if they
like.

BTW, Paul, were you actually reviewing this?
Comment 12 Paul Wouters 2007-05-26 18:41:29 EDT
Yes I am. I've assigned the item to me and added the ? review flag.
Comment 13 Wes Hardaker 2007-05-31 19:03:33 EDT
1) done
2) done
3) ugh.  It's taken me a bit, but I'd lay down money that you have a conflicting
Digest/SHA.pm somewhere on your system.  Probably in site_perl.  I actually had
the same issue on one system, and it turns out that my installed site_perl
version is missing a glob line that the real version has.  The instant I removed
the conflicting site_perl version the problem went away.
Comment 14 Wes Hardaker 2007-05-31 19:05:16 EDT
Spec URL: http://www.hardakers.net/FE/perl-Digest-SHA.spec
SRPM URL: http://www.hardakers.net/FE/perl-Digest-SHA-5.44-4.src.rpm

* Thu May 31 2007 Wes Hardaker <wjhns174@hardakers.net> - 5.44-4
- fix description clause to remove hyphenation
- pass optimization flags to Makefile.PL

* Mon May 14 2007  Wes Hardaker <wjhns174@hardakers.net> - 5.44-4
- Reverse terms in license to match perl rpm exactly
Comment 15 Wes Hardaker 2007-05-31 19:06:56 EDT
BTW, I agree: hyphenation shouldn't be done in general any longer.  Though it
doesn't really matter.  I did remove it from the spec file (but Jason is right,
it came from pod output)
Comment 16 Wes Hardaker 2007-05-31 20:43:18 EDT
Paul: could you change the status to "Assigned"?  It's still marked as "NEW"
even though it has you as the email assignment.  The status is wrong (I'd do it,
but...)
Comment 17 Wes Hardaker 2007-05-31 20:43:54 EDT
whoops.  accidentally *did* do it.  Change back to new if you don't want it.
Comment 18 Paul Wouters 2007-06-01 11:12:05 EDT
Indeed, seems I had
/usr/lib64/perl5/site_perl/5.8.6/x86_64-linux-thread-multi/Digest/SHA.pm
which was not part of any package.
Removing it fixed the issue.

[paul@bofh paul]> /usr/bin/shasum /usr/share/man/man1/shasum.1.gz
7b11167cfefb38ceea29a182cbed2c75bc7da3ab  /usr/share/man/man1/shasum.1.gz
[paul@bofh paul]> /usr/bin/sha1sum /usr/share/man/man1/shasum.1.gz
7b11167cfefb38ceea29a182cbed2c75bc7da3ab  /usr/share/man/man1/shasum.1.gz

Looks good.

Changelog seems to have two entries for the same version now:

* Thu May 31 2007 Wes Hardaker <wjhns174@hardakers.net> - 5.44-4
- fix description clause to remove hyphenation
- pass optimization flags to Makefile.PL

So change that and bump it to 5.44-5.

APPROVED.
Comment 19 Wes Hardaker 2007-06-01 11:49:29 EDT
New Package CVS Request
=======================
Package Name: perl-Digest-SHA
Short Description: Perl support for SHA digests
Owners: wjhns174@hardakers.net
Branches: FC-6 F-7
InitialCC: 
Comment 20 Jason Tibbitts 2007-06-01 16:13:03 EDT
CVS done.
Comment 21 Wes Hardaker 2007-06-20 17:39:23 EDT
Sorry for the delay in actually getting this in, but it is now.  (work crunch
time and a dead hard disk played the major roles).

Note You need to log in before you can comment on or make changes to this bug.