Bug 237358 - File permission checks don't correspond with error messages
Summary: File permission checks don't correspond with error messages
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: audit   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Steve Grubb
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-21 01:31 UTC by Miloslav Trmač
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-02 17:16:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Modify the permission checks (2.71 KB, patch)
2007-04-21 01:34 UTC, Miloslav Trmač
no flags Details | Diff

Description Miloslav Trmač 2007-04-21 01:31:53 UTC
Description of problem:
When config files reference file paths, the file permission checks performed on
the files don't match the error messages used when the checks fail.

Version-Release number of selected component (if applicable):
audit-1.5.2-1.fc7

Comment 1 Miloslav Trmač 2007-04-21 01:34:23 UTC
Created attachment 153231 [details]
Modify the permission checks

The attached patch (only compile-tested) makes the permission checks consistent
with the messages.  I was not sure what the permission requirements actually
are, so the changes are just my best guess at the intended semantics.

Comment 2 Steve Grubb 2007-05-01 18:39:39 UTC
I applied a variation of this patch to 1.5.3. Thanks for spotting the problem.

Comment 3 Steve Grubb 2007-05-02 17:16:17 UTC
audit-1.5.3 was built into rawhide and should solve this problem. Thanks for
reporting it.


Note You need to log in before you can comment on or make changes to this bug.