Bug 237386 - clvmd and quorum disk prevents lvextend/lvremove
clvmd and quorum disk prevents lvextend/lvremove
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christine Caulfield
Cluster QE
:
: 299871 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-21 14:05 EDT by Scott Bachmann
Modified: 2010-01-11 23:08 EST (History)
7 users (show)

See Also:
Fixed In Version: RHBA-2007-0518
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 14:10:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to fix (1.31 KB, patch)
2007-04-23 09:33 EDT, Christine Caulfield
no flags Details | Diff

  None (edit)
Description Scott Bachmann 2007-04-21 14:05:39 EDT
Description of problem:
When attempting to extend a logical volume (and other LV modifications), the 
clvmd daemon attempts to contact all nodes in the cluster.  If the cluster is 
using a quorum disk, clvmd attempts to contact this "node" and times out.

This is the similar to bugs <a 
href="https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=223519">#223519</a> 
and 
<a 
href="https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=234589">#235689</a>

Version-Release number of selected component (if applicable):
lvm2-cluster-2.02.16-3.el5 (RHEL5 Stock)

How reproducible:
Very

Steps to Reproduce:
1. Configure a cluster with a quorum disk
2. "service cman start" on both nodes
3. "service qdiskd start" on both nodes
4. "service clvmd start" on both nodes
5. "lvextend -L +4M /dev/vg-vms/lv-website"
  
Actual results:
Error locking on node /dev/dm-3: Command timed out
Failed to suspend lv-website

Expected results:
Logical volume lv-website successfully resized

Additional info:
These systems are running cman-2.0.60, with two additional patches from bugs 
#223519 and #230972 for proper quorum disk functionality.  The quorum disk is 
not part of a LVM, and is /dev/dm-3 (as shown above).
Comment 1 Christine Caulfield 2007-04-23 09:33:39 EDT
Created attachment 153280 [details]
Proposed patch to fix
Comment 2 Scott Bachmann 2007-04-23 10:41:57 EDT
Hi Patrick,

I applied the proposed patch to the lvm2-cluster-2.02.16-3.el5 source RPM, and 
it does indeed resolve the issues.

Thanks!
Scott
Comment 3 Christine Caulfield 2007-04-23 10:56:09 EDT
Thanks for testing that,

Now checked in :

Checking in daemons/clvmd/clvmd-cman.c;
/cvs/lvm2/LVM2/daemons/clvmd/clvmd-cman.c,v  <--  clvmd-cman.c
new revision: 1.17; previous revision: 1.16
done
Comment 4 Kiersten (Kerri) Anderson 2007-04-23 13:30:50 EDT
Fixing Product Name.  Cluster Suite components were integrated into the
Enterprise Linux version 5.0.
Comment 6 RHEL Product and Program Management 2007-05-01 13:30:34 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Christine Caulfield 2007-09-25 03:06:01 EDT
*** Bug 299871 has been marked as a duplicate of this bug. ***
Comment 11 errata-xmlrpc 2007-11-07 14:10:15 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0518.html

Note You need to log in before you can comment on or make changes to this bug.