Bug 237405 - Kernel panic on boot
Kernel panic on boot
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-21 23:48 EDT by Ahmed G.
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 06:34:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci and dmesg output (5.72 KB, application/x-gzip)
2007-04-21 23:48 EDT, Ahmed G.
no flags Details
dmesg from Fedora kernel (fc6 I believe, since f7 kernels have not really worked since I starting using rawhide) (15.01 KB, text/plain)
2007-04-23 19:35 EDT, Ahmed G.
no flags Details
lspci -vv output from Fedora. (3.63 KB, text/plain)
2007-04-23 19:42 EDT, Ahmed G.
no flags Details
requested fstab (601 bytes, text/plain)
2007-04-25 18:06 EDT, Ahmed G.
no flags Details

  None (edit)
Description Ahmed G. 2007-04-21 23:48:29 EDT
Description of problem:
Booting the computer fails, with kernel panic and problems finding modprobe. 


Version-Release number of selected component (if applicable):
All the Fedora 7 kernels have given me this problem.

How reproducible:
Every Time

Steps to Reproduce:
1.Boot
2.Choose Fedora 7 kernel
3.Wait for the panic.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ahmed G. 2007-04-21 23:48:29 EDT
Created attachment 153248 [details]
lspci and dmesg output
Comment 2 Dave Jones 2007-04-23 11:17:32 EDT
I need to see the actual panic messages to diagnose this.
The dmesg you attached is not a fedora kernel, so isn't useful.
Comment 3 Ahmed G. 2007-04-23 19:35:30 EDT
Created attachment 153325 [details]
dmesg from Fedora kernel (fc6 I believe, since f7 kernels have not really worked since I starting using rawhide)

Here is the Fedora based dmesg output. The 2.6.18-1.2869.fc6 kernel was the
only one I had installed that would work for me. (All the others are for F7)
Comment 4 Ahmed G. 2007-04-23 19:42:21 EDT
Created attachment 153326 [details]
lspci -vv output from Fedora.

Updated lspci output, this time it's from Fedora. Also I would like to add the
Errors and start up. They are:

SCSI Subsystem Initialized
libata version 2.20 loaded
Unable to access resume device (Label=swap- afaaaa98-8)
mount could not find filesystem '/dev/root'
setuproot: moving /dev failed: no such file or directory
setuproot: error mounting /proc : no such file or directory
setuproot: error mounting /sys :  no such file or directory
switchroot: mount failed :  no such file or directory
Kernel Panic - not syncing : attempt to kill init!


That's where the boot stops. I hope this is helpful.
Comment 5 Dave Jones 2007-04-24 11:39:27 EDT
that label looks odd, can you paste your /etc/fstab ?
Comment 6 Ahmed G. 2007-04-25 18:06:54 EDT
Created attachment 153463 [details]
requested fstab
Comment 7 Ahmed G. 2007-04-25 18:10:04 EDT
Comment on attachment 153463 [details]
requested fstab

Weird label is the result of a strange naming method of an early live-cd
installer build.
Comment 8 Ahmed G. 2007-05-02 17:43:11 EDT
Is there anything else that is needed from me at this point, or what is the
status  of this? (Not to sound impatient, I'm just curious).
Comment 9 Chuck Ebbert 2007-05-02 18:09:50 EDT
Can you post the initrd for the failing install?
Comment 10 Ahmed G. 2007-05-02 20:42:30 EDT
I'm sorry, I don't understand. I haven't used the "install" cds only the live
cds. When the live-cd for Fedora 7 failed, I used a Fedora 6 live cd with an
early implementation of the installer (not using anaconda). Once the FC6 system
was installed I upgraded to raw-hide from there. The problems have been the
same. I tried rebuilding the initrd with other modules, but this did not really
help.
Comment 11 Ahmed G. 2007-05-17 22:45:30 EDT
What is the status on this?
Comment 12 Dave Jones 2007-10-11 02:29:26 EDT
we really need to see the initrd.img to debug this further.
Comment 13 Ahmed G. 2007-10-11 06:33:39 EDT
This is old the problem was fixed already, I though this bug was closed.
Comment 14 Ahmed G. 2007-10-11 06:35:52 EDT
thought*

Note You need to log in before you can comment on or make changes to this bug.