Bug 237405 - Kernel panic on boot
Summary: Kernel panic on boot
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
Depends On:
TreeView+ depends on / blocked
Reported: 2007-04-22 03:48 UTC by Ahmed G.
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-10-11 10:34:46 UTC
Type: ---

Attachments (Terms of Use)
lspci and dmesg output (5.72 KB, application/x-gzip)
2007-04-22 03:48 UTC, Ahmed G.
no flags Details
dmesg from Fedora kernel (fc6 I believe, since f7 kernels have not really worked since I starting using rawhide) (15.01 KB, text/plain)
2007-04-23 23:35 UTC, Ahmed G.
no flags Details
lspci -vv output from Fedora. (3.63 KB, text/plain)
2007-04-23 23:42 UTC, Ahmed G.
no flags Details
requested fstab (601 bytes, text/plain)
2007-04-25 22:06 UTC, Ahmed G.
no flags Details

Description Ahmed G. 2007-04-22 03:48:29 UTC
Description of problem:
Booting the computer fails, with kernel panic and problems finding modprobe. 

Version-Release number of selected component (if applicable):
All the Fedora 7 kernels have given me this problem.

How reproducible:
Every Time

Steps to Reproduce:
2.Choose Fedora 7 kernel
3.Wait for the panic.
Actual results:

Expected results:

Additional info:

Comment 1 Ahmed G. 2007-04-22 03:48:29 UTC
Created attachment 153248 [details]
lspci and dmesg output

Comment 2 Dave Jones 2007-04-23 15:17:32 UTC
I need to see the actual panic messages to diagnose this.
The dmesg you attached is not a fedora kernel, so isn't useful.

Comment 3 Ahmed G. 2007-04-23 23:35:30 UTC
Created attachment 153325 [details]
dmesg from Fedora kernel (fc6 I believe, since f7 kernels have not really worked since I starting using rawhide)

Here is the Fedora based dmesg output. The 2.6.18-1.2869.fc6 kernel was the
only one I had installed that would work for me. (All the others are for F7)

Comment 4 Ahmed G. 2007-04-23 23:42:21 UTC
Created attachment 153326 [details]
lspci -vv output from Fedora.

Updated lspci output, this time it's from Fedora. Also I would like to add the
Errors and start up. They are:

SCSI Subsystem Initialized
libata version 2.20 loaded
Unable to access resume device (Label=swap- afaaaa98-8)
mount could not find filesystem '/dev/root'
setuproot: moving /dev failed: no such file or directory
setuproot: error mounting /proc : no such file or directory
setuproot: error mounting /sys :  no such file or directory
switchroot: mount failed :  no such file or directory
Kernel Panic - not syncing : attempt to kill init!

That's where the boot stops. I hope this is helpful.

Comment 5 Dave Jones 2007-04-24 15:39:27 UTC
that label looks odd, can you paste your /etc/fstab ?

Comment 6 Ahmed G. 2007-04-25 22:06:54 UTC
Created attachment 153463 [details]
requested fstab

Comment 7 Ahmed G. 2007-04-25 22:10:04 UTC
Comment on attachment 153463 [details]
requested fstab

Weird label is the result of a strange naming method of an early live-cd
installer build.

Comment 8 Ahmed G. 2007-05-02 21:43:11 UTC
Is there anything else that is needed from me at this point, or what is the
status  of this? (Not to sound impatient, I'm just curious).

Comment 9 Chuck Ebbert 2007-05-02 22:09:50 UTC
Can you post the initrd for the failing install?

Comment 10 Ahmed G. 2007-05-03 00:42:30 UTC
I'm sorry, I don't understand. I haven't used the "install" cds only the live
cds. When the live-cd for Fedora 7 failed, I used a Fedora 6 live cd with an
early implementation of the installer (not using anaconda). Once the FC6 system
was installed I upgraded to raw-hide from there. The problems have been the
same. I tried rebuilding the initrd with other modules, but this did not really

Comment 11 Ahmed G. 2007-05-18 02:45:30 UTC
What is the status on this?

Comment 12 Dave Jones 2007-10-11 06:29:26 UTC
we really need to see the initrd.img to debug this further.

Comment 13 Ahmed G. 2007-10-11 10:33:39 UTC
This is old the problem was fixed already, I though this bug was closed.

Comment 14 Ahmed G. 2007-10-11 10:35:52 UTC

Note You need to log in before you can comment on or make changes to this bug.