Bug 237406 - Copying files via NFS mount pauses indefinitely
Summary: Copying files via NFS mount pauses indefinitely
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-22 04:01 UTC by Brian Chadwick
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 23:58:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Chadwick 2007-04-22 04:01:20 UTC
Description of problem: When copying many SMALL files from a mounted NFS file
system, the copy process will copy some files, then pause indefinitely, then
copy some more, then pause again. 


Version-Release number of selected component (if applicable):

2.6.20-1.2944.fc6


How reproducible:

all the time. DOES NOT HAPPEN WITH ORIGINAL 2.6.18-1.2798.fc6 KERNEL


Steps to Reproduce:
1. mount nfs file system
2. copy a directory with hundreds of small files
3. Reverting to old kernel, no problems appear.
  
Actual results:


Expected results:


Additional info:

Comment 1 Brian Chadwick 2007-04-22 04:08:34 UTC
The pauses are VERY long, so much so that NFS is unusable for copying a large
directory full of small files. Copying one large file however does not cause any
problem. It seems to be related to the number of files, not the size.

Comment 2 Brian Chadwick 2007-06-16 03:42:59 UTC
Further investigation reveals that this behaviour is dependant on the type of
ethernet NIC. Changing to another card type (e100) clears the problem. The
faulty behaviour occurs with the "forcedeth" driver for nVidia NIC nForce 2
ethernet controller. Should I file another bug?

Comment 3 Steve Dickson 2007-08-29 23:58:28 UTC
If the problem continues to exist, Yes.


Note You need to log in before you can comment on or make changes to this bug.