Bug 237413 - Detection of Pegasos platform is broken.
Summary: Detection of Pegasos platform is broken.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-04-22 10:41 UTC by David Woodhouse
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-09 17:34:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Always check machine before platform (1.10 KB, patch)
2007-04-22 10:43 UTC, David Woodhouse
no flags Details | Diff

Description David Woodhouse 2007-04-22 10:41:57 UTC
The installer seems to be insisting that I have a PReP partition on my Pegasos
machine. It doesn't need one -- and because it has Amiga partitions, it can't
_have_ one, so the install fails. 

Pegasos has this in /proc/cpuinfo:

platform : CHRP
machine  : CHRP Pegasos2

IIRC, we used to look at just the 'machine' line -- and because Pegasos was in
the  ppcType table before CHRP, it would be correctly identified as Pegasos. But
now we seem to look at whichever comes first out of machine and platform, so
just 'CHRP' is seen, not 'CHRP Pegasos2'.

Comment 1 David Woodhouse 2007-04-22 10:43:49 UTC
Created attachment 153249 [details]
Always check machine before platform

This patch makes Pegasos happy again, by always checking the machine line
before platform. I'll test on Maple too...

Comment 2 David Woodhouse 2007-04-22 10:46:44 UTC
Patched version still works on PS3 where we have only 'platform' and not
'machine'. I believe that's the case on Maple too, which is why we made the
offending change in the first place. Will test though.

Comment 3 Chris Lumens 2007-05-09 17:34:55 UTC
Committed.


Note You need to log in before you can comment on or make changes to this bug.