This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 237425 - Yum doesn't read options set by plugins in repository configuration files
Yum doesn't read options set by plugins in repository configuration files
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-04-22 13:29 EDT by Jonathan Dieter
Modified: 2014-01-21 17:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-26 09:31:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Dieter 2007-04-22 13:29:52 EDT
Description of problem:
In fedora-development.repo, we have the line:
deltaurl=http://www.lesbg.com/jdieter/updates/development/$basearch

In the yum-presto plugin, there's the following code:
def config_hook(conduit):
    # Set up repository specific deltarpm url and mirrorlist
    config.RepoConf.deltaurl = config.UrlListOption()

Later, in postreposetup_hook, we try to access this configuration with:
    print repo.deltaurl
where repo is an active repository (we actually loop through all of them).

The result:
None for all active repositories (including development)

Version-Release number of selected component (if applicable):
yum-3.1.6-2.fc7

How reproducible:
Always
Comment 1 Jonathan Dieter 2007-04-22 23:53:45 EDT
I suspect this is related to
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=236512.  I would guess that
the configuration options aren't getting set before postreposetup_hook (along
with the rest of the repository information).
Comment 2 Jeremy Katz 2007-04-25 21:59:15 EDT
James -- this is due to some of the metaclass magic... we only set up the
options that get looked at for the config objects when the classes are created
as opposed to letting plugins add options to the classes before they're
instantiated.

Comment 3 James Bowes 2007-04-26 09:31:21 EDT
I've reverted the metaclass changes to the config module, so everything will be
as once it was.

Note You need to log in before you can comment on or make changes to this bug.