Bug 237431 - ValueError: invalid literal for int() with base 10: ''
ValueError: invalid literal for int() with base 10: ''
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-22 18:11 EDT by Jasper O. Hartline
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-23 10:39:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt traceback dump from Anaconda (14.73 KB, text/plain)
2007-04-22 18:11 EDT, Jasper O. Hartline
no flags Details

  None (edit)
Description Jasper O. Hartline 2007-04-22 18:11:08 EDT
Description of problem:
While testing out Anaconda from the development repository, and it's
capabilities with Kadischi to install systems from a LiveCD, upon running the
operation in a standard machine with standard peripherals, Anaconda tracebacks
with the attached data. The traceback occurs after partition and Grub selection
setups, right at the point where you would normally see the Network
Configuration screen questions.

NOTE: This traceback DID NOT OCCUR IN ALL MACHINES TESTED.

Version-Release number of selected component (if applicable):
anaconda-11.2.0.54-2

How reproducible:
Run a kadischi built LiveCD with Anaconda in a machine with the following devices: 
[autopsy@localhost floppy]$ /sbin/lspci
00:00.0 Host bridge: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM
Controller/Host-Hub Interface (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE
Chipset Integrated Graphics Device (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 82)
00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface
Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 02)
01:0a.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
01:0c.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
[autopsy@localhost floppy]$ /sbin/lsusb
Bus 001 Device 001: ID 0000:0000  
Bus 004 Device 001: ID 0000:0000  
Bus 004 Device 002: ID 0ecd:1402 Lite-On IT Corp. 
Bus 002 Device 001: ID 0000:0000  
Bus 003 Device 001: ID 0000:0000  
[autopsy@localhost floppy]$

Steps to Reproduce:
1. Run Anaconda under Kadischi from LiveCD
2.
3.
  
Actual results:
System tracebacked.

Expected results:
Should have continued the installation instead of tracing back.

Additional info:
There is a anacdump.txt attached which was saved to a floppy.
Comment 1 Jasper O. Hartline 2007-04-22 18:11:08 EDT
Created attachment 153260 [details]
anacdump.txt traceback dump from Anaconda
Comment 2 David Cantrell 2007-04-23 10:39:04 EDT
The problem here is you have three network devices: eth0, wlan0, and wmaste. 
The third device does not match the [a-zA-Z]+[0-9]+ pattern we assume devices
are named with (i.e., there is no integer at the end of wmaste).  So int()
throws an exception since we are handing it an empty string.

I've wrapped the two int() calls in a try/except.  If an exception occurs, the
function returns zero.  Not sure if we want to do this or not because I'm not
sure how the sorting will end up, but it shouldn't traceback now.

Note You need to log in before you can comment on or make changes to this bug.