Bug 237442 - glchess backtrace
glchess backtrace
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: glchess (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-23 02:28 EDT by Per Nystrom
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-27 04:46:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Per Nystrom 2007-04-23 02:28:27 EDT
Description of problem:

Trying to submit a bug on glchess is FC6, and there's no component for it on the
submission page (though the glchess component *does* exist on the query page).

Once that's straightened out, here's my problem:

$ glchess 
Traceback (most recent call last):
  File "/usr/bin/glchess", line 7, in ?
    app = glchess.main.Application()
  File "/usr/lib/python2.4/site-packages/glchess/main.py", line 1047, in __init__
    self.ui = UI(self)
  File "/usr/lib/python2.4/site-packages/glchess/main.py", line 956, in __init__
    self.splashscreen = Splashscreen(self)
  File "/usr/lib/python2.4/site-packages/glchess/main.py", line 361, in __init__
    self.scene = scene.opengl.Scene(self)
TypeError: __init__() takes exactly 1 argument (2 given)

$ rpm -q glchess python
glchess-1.0.5-1.fc6
python-2.4.4-1.fc6
Comment 1 David Lawrence 2007-04-23 09:46:08 EDT
The component for glchess is actually under the product 'Fedora Extras'. I am
changing this bug to that component so the developer will see it.
Comment 2 Hans de Goede 2007-04-27 04:46:43 EDT
This error is caused by PyOpenGL missing a Requires: python-ctypes, which in
turn causes glchess to dive into a normally unused code-path, which causes the
traceback.

I've just requested a build of PyOpenGL-3.0.0-0.3.a6.fc6.1, which adds the
missing Requires. I'll also issue an update to glchess, so that it will not
cause a backtrace even when PyOpenGL is missing / not functional.

You can fix this manually with "yum install python-ctypes" (which will get
installed automaticly on the next yum update when the updates have hit the repo).

Note You need to log in before you can comment on or make changes to this bug.