Bug 23747 - telnet server does not work
Summary: telnet server does not work
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: telnet   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard: Florence Beta-3
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-10 22:28 UTC by Joseph Kotran
Modified: 2007-04-18 16:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-18 17:31:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joseph Kotran 2001-01-10 22:28:50 UTC
Hello,

	Please note that I am unable to telnet to a newly installed beta 2 node.

				Regards,

_______________________________________________________________________
 
Joseph Kotran                           Lead Systems Administrator
 
Lockheed Martin                         E-mail: jkotran@atl.lmco.com
Advanced Technology Laboratories        Phone:  856.338.4327
1 Federal St A&E 312                    Fax:    856.338.4121
Camden NJ USA 08102                     Web:    http://www.atl.lmco.com

Comment 1 Jeremy Katz 2001-01-11 05:57:18 UTC
Have you enabled telnet either via chkconfig or setting 'disable=no' in
/etc/xinetd.d/telnet after installing the package and then restarted xinetd?

Comment 2 Daniel Roesen 2001-01-11 12:50:16 UTC
Security bites! :-]

(and I'm all for heavy biting)

Comment 3 Joseph Kotran 2001-01-11 16:38:54 UTC
Hello,

	I did enable telnet in /etc/xinetd.d/telnet and I sent a HUP signal to the
xinetd.  I recently restarted xinetd and I can now telnet to the computer.  Does
xinetd require a restart when you change its configuration?  I think that this
would cause problems on a server that is accessed by many users.  I think that a
key service such as inetd should always be running.

				Regards,

				Joe Kotran


Comment 4 Jeremy Katz 2001-01-11 16:44:08 UTC
xinetd should run by default, but a SIGHUP does not restart xinetd.  This is a
behavior change between inetd and xinetd -- from xinetd(8)

       SIGHUP         causes  an internal state dump (the default
                      dump file is  /tmp/xinetd.dump;  to  change
                      the filename, edit config.h and recompile).

Therefore, you must do a restart of the service to get the configuration files
reread.  This is identical behavior to 7.0 except for the fact that telnet is
not enabled by default due to security considerations.

Comment 5 Glen Foster 2001-01-11 21:16:28 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 6 Tim Waugh 2001-01-18 17:13:25 UTC
Er.. '/sbin/service xinetd reload' (which sends a SIGUSR2) works just fine, doesn't it?  Seems like NOTABUG to me..

Comment 7 Jeremy Katz 2001-01-18 17:31:25 UTC
That was my thinking but I was going to let Jeff or Joseph make the call :)

Comment 8 Jeff Johnson 2001-01-18 17:37:29 UTC
We have consensus.


Note You need to log in before you can comment on or make changes to this bug.