Bug 237472 - dell chron job dosent email its log properly
dell chron job dosent email its log properly
Status: CLOSED NOTABUG
Product: Red Hat Web Site
Classification: Red Hat
Component: Product_Activation (Show other bugs)
wsd245
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jordan OMara
Web Development
http://www.redhat.com/wapps/dellactivate
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-23 08:52 EDT by joseph canton
Modified: 2014-11-09 17:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 13:20:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joseph canton 2007-04-23 08:52:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.10) Gecko/20070312 Red Hat/1.5.0.10-2.el5 Firefox/1.5.0.10

Description of problem:
The dell chron job running on live at about 4 am and 4pm should email a log file attachment to webdev-spam-list (as set on the command line). The email may be "several" emails, each with an attachment, numbered 1,2,... 12 of 12  etc.
I see only the last of the sequence.

the subject of this mornings last log email is:
"A1000 Normal End Dell Svc Tag Log-26 of 26".

There is another emailed report, the "Exception report" which is being emailed properly.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1 job runs at 4am and 4 pm on Live.
2.look for output emails'
3.

Actual Results:
Only last of several log emails appear in webdev-spam-list

Expected Results:
All emails should apper.

Additional info:
There can be a 3rd email, 'WebAlert' not to be confused with the emails previously discussed.
Comment 1 Mark Sechrest 2007-08-13 16:41:53 EDT
Moved to wsd245
Comment 2 Chris Duryee 2007-08-29 14:01:25 EDT
Currently, we can't develop or test perl cronjobs because the versions of RHEL
and perl are different in QA, STAGE, and prod for the batch machine.

Currently, QA has RHEL5, STAGE has RHEL4, and prod has RHEL2.1. Each environment
also has different perl versions.

Once all environments are leveled to RHEL5, we can proceed with fixing this bug.

Comment 3 Chris Duryee 2007-08-29 15:57:23 EDT
We decided to just make very minimal changes to disable some logging, in order
to ensure compatibility between versions.

This needs to be revisited later though.
Comment 4 Chris Duryee 2007-08-30 08:34:00 EDT
r21467. I'll work with RE to get this QA'd.
Comment 5 manoj 2007-09-19 11:37:20 EDT
Beav,

Were you able to fix this.

Manoj
Comment 6 Chris Duryee 2007-09-20 08:36:34 EDT
yes
Comment 7 Steve Milner 2007-09-26 20:47:15 EDT
Updated to ON_QA buy bugzillaupdater
Comment 8 Denise Hughes 2007-10-11 12:50:10 EDT
QA review: need Chris Duryee and RE to validate.
Comment 9 joseph canton 2009-04-21 11:15:07 EDT
can someone close this bug?  joe
Comment 10 Steve Milner 2009-04-30 13:43:41 EDT
@joe yeah, I was thinking the same thing.
Comment 11 joseph canton 2009-08-31 13:20:11 EDT
THis is ancient history, was fixed or forgotten. I'm closing it. Re-open if needed.

Note You need to log in before you can comment on or make changes to this bug.