Bug 23748 - /etc/hosts does not include a line for node's hostname
Summary: /etc/hosts does not include a line for node's hostname
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-10 22:32 UTC by Joseph Kotran
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-02 15:37:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joseph Kotran 2001-01-10 22:32:09 UTC
Hello,

	Please note that after a clean install of beta 2 /etc/hosts does not
contain an entry for the node's hostname.  The node is a DHCP client.

Example:

127.0.0.1	localhost.localdomain	localhost

192.168.221.50	kismet.domain.com	kismet
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^   NOT ADDED BY ANACONDA

				Best regards,

				Joe Kotran

Comment 1 Daniel Roesen 2001-01-11 12:52:04 UTC
Wouldn't that be correct? I mean if your host is a DHCP client its IP address
changes anyway?!?

Comment 2 Joseph Kotran 2001-01-11 16:46:13 UTC
Good day,

	Our DHCP client's IP addresses do not change.  We use DHCP to reduce
configuration errors and to save Systems Administration time.  We use static
address for security and development purposes.  A number of our developers
depend upon a fixed IP address.

				Joe Kotran

P.S.  Also, the Solaris DHCP client does add the host information to
/etc/hosts.  This is true for both static and dynamic addresses.


Comment 3 Erik Troan 2001-04-02 21:54:43 UTC
Anaconda is correct because of setups with dynamic dns, for example. Not adding
this doesn't hurt your situation, but it can hurt others.


Note You need to log in before you can comment on or make changes to this bug.