Bug 237482 - CUPS backend installed in wrong place
CUPS backend installed in wrong place
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bluez-utils (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-23 10:25 EDT by Tim Waugh
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-21 07:00:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2007-04-23 10:25:35 EDT
Description of problem:
The CUPS backend directory is: /usr/lib/cups/backend
It is *not*: %{_libdir}/cups/backend
Please install the CUPS backend in /usr/lib/cups/backend.

Version-Release number of selected component (if applicable):
bluez-utils-cups-3.7-2

Background: by rights it ought to be /usr/libexec/cups/backend, however the
'libexec' directory is not in enough standards to satisfy the upstream CUPS
maintainer, so we use /usr/lib for consistency's sake to allow 3rd party
filters/backends/etc.
Comment 1 Bastien Nocera 2007-05-22 13:37:00 EDT
It looks like cups is still capable of printing using the bluetooth backend with
that problem, but it means that Bluetooth printer doesn't show up in
system-config-printer, or the HAL config interface.
Comment 2 Tim Waugh 2007-05-23 04:12:28 EDT
Really?  If it knows where the backend is, it knows where it is.  I patched
cupsd so that it looks in /usr/lib/cups first, and then /usr/lib64/cups if we
ever used that location before on that architecture, so it will *find* the
backend currently.  I won't keep that 'legacy location' patch around forever though.

I think perhaps the bluetooth backend isn't performing discovery.
Comment 3 Bastien Nocera 2007-05-23 04:39:22 EDT
I did "sudo cp /usr/lib64/cups/backend/bluetooth /usr/lib/cups/backend/" and it
showed up in the list afterwards.
Comment 4 Tim Waugh 2007-05-23 04:48:27 EDT
Hm, didn't realise that effect.  Then it's even more important to ship it in the
correct place..
Comment 5 Bastien Nocera 2007-05-29 13:02:49 EDT
I've moved the backend in bluez-utils-3.11-1 in devel.

Note You need to log in before you can comment on or make changes to this bug.