Bug 237496 - Missing dependencies
Summary: Missing dependencies
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: graphviz (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jima
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-23 15:06 UTC by Matthias Clasen
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 2.12-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 14:48:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for second part of bug report (906 bytes, patch)
2007-04-23 16:32 UTC, John Ellson
no flags Details | Diff

Description Matthias Clasen 2007-04-23 15:06:19 UTC
Some of the graphviz libraries are insufficiently linked:

[mclasen@dhcp83-33 ~]$ ldd -r /usr/lib/libgvc_builtins.so.3
        linux-gate.so.1 =>  (0x00122000)
        libcdt.so.3 => /usr/lib/libcdt.so.3 (0x004d6000)
        libgraph.so.3 => /usr/lib/libgraph.so.3 (0x00b51000)
        libpathplan.so.3 => /usr/lib/libpathplan.so.3 (0x00e6f000)
        libexpat.so.0 => /lib/libexpat.so.0 (0x00314000)
        libz.so.1 => /lib/libz.so.1 (0x0079b000)
        libltdl.so.3 => /usr/lib/libltdl.so.3 (0x00db4000)
        libc.so.6 => /lib/libc.so.6 (0x00bfb000)
        libm.so.6 => /lib/libm.so.6 (0x008fc000)
        libdl.so.2 => /lib/libdl.so.2 (0x00110000)
        /lib/ld-linux.so.2 (0x80000000)
undefined symbol: Demand_Loading        (/usr/lib/libgvc_builtins.so.3)
undefined symbol: lt_preloaded_symbols  (/usr/lib/libgvc_builtins.so.3)


[mclasen@dhcp83-33 ~]$ ldd -r /usr/lib/libexpr.so.3
undefined symbol: Dtoset        (/usr/lib/libexpr.so.3)
undefined symbol: Dtset linux-gate.so.1 =>  (0x008b0000)
        libc.so.6 => /lib/libc.so.6 (0x00a7b000)
        /lib/ld-linux.so.2 (0x80000000)
        (/usr/lib/libexpr.so.3)
undefined symbol: dtwalk        (/usr/lib/libexpr.so.3)
undefined symbol: dtclose       (/usr/lib/libexpr.so.3)
undefined symbol: dtview        (/usr/lib/libexpr.so.3)
undefined symbol: dtopen        (/usr/lib/libexpr.so.3)

Comment 1 Jima 2007-04-23 16:17:01 UTC
I have no idea where to even begin with this, but I just want to say "I'm
looking at it."

Comment 2 John Ellson 2007-04-23 16:18:20 UTC
The first is ok, I think.   The library is expected to be used with something like:
    dot_static_SOURCES = dot.c $(top_srcdir)/lib/gvc/no_demand_loading.c
    dot_static_LDFLAGS = -export-dynamic -dlpreopen self -export-symbols-regex
'.*_LTX_library'

See: cmd/dot/Makefile.am   or: dot.demo/Makefile.builtins  in the sources


The second looks like a bug ( requires -lcdt ).   I'll fix this upstream.

Comment 3 Jima 2007-04-23 16:19:46 UTC
Thanks for chiming in, John. :-)

Comment 4 John Ellson 2007-04-23 16:32:40 UTC
Created attachment 153293 [details]
Fix for second part of bug report

Comment 5 Jima 2007-08-29 14:48:42 UTC
Reviewing my old, open bugs...looks like I applied John's fix nearly four months
ago.  This should have been resolved as of 2.12-7; closing this bug.

Thanks folks!


Note You need to log in before you can comment on or make changes to this bug.