Bug 237509 - floppy disk absent/change notice handled badly
Summary: floppy disk absent/change notice handled badly
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-23 16:02 UTC by Zing
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: f7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-07 15:22:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zing 2007-04-23 16:02:53 UTC
Description of problem:
I needed to write out a bunch of floppy image files with dd to /dev/fd0 and
every first write to the next floppy would fail.  Trying immediately again,
would succeed.

Version-Release number of selected component (if applicable):
kernel-2.6.20-1.2944.fc6

How reproducible:
all the time, tested on two different fc6 machines.

Steps to Reproduce:
1. Insert a floppy.
2. $ dd if=/dev/zero of=/dev/fd0 count=1 bs=1000

data written out correctly:

1+0 records in
1+0 records out
1000 bytes (1.0 kB) copied, 0.0909503 seconds, 11.0 kB/s

3. remove floppy.
4. insert floppy back into drive.
5. $ dd if=/dev/zero of=/dev/fd0 count=1 bs=1000

error:
floppy0: disk absent or changed during operation
end_request: I/O error, dev fd0, sector 0
dd: writing `/dev/fd0': Input/output error
1+0 records in
0+0 records out
0 bytes (0 B) copied, 0.0209154 seconds, 0.0 kB/s

6. rerun dd command from step 5.

write succeeds.


Actual results:

step 5. fails.

Expected results:

step 5. should succeed. kernel is confused.

Additional info:

Haven't had to use the floppy in awhile, but this worked correctly at some point
in the past.

Comment 1 Pete Zaitcev 2007-08-07 01:04:04 UTC
Is this still a problem? How about Fedora 7?

I do not have an FC-6 box with a floppy, but RHEL-5 and F-7 seem ok in my
testing (tried with stopped HAL).


Comment 2 Zing 2007-08-07 13:25:04 UTC
Both machines are F7 now and the floppy works... you mention hal and I wonder if
that was the cause of the original problem.  Regardless, the disk change seems
to work fine now with haldaemon running or not.  thanks.


Note You need to log in before you can comment on or make changes to this bug.