Bug 237526 - DVD installer hangs at "Ready." message
DVD installer hangs at "Ready." message
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Brock Organ
:
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-04-23 13:24 EDT by Simon Goodall
Modified: 2013-01-09 23:16 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-01 04:44:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output (12.25 KB, text/plain)
2007-04-23 13:24 EDT, Simon Goodall
no flags Details
disk errors (1.64 KB, text/plain)
2007-04-25 16:08 EDT, Simon Goodall
no flags Details

  None (edit)
Description Simon Goodall 2007-04-23 13:24:54 EDT
Not sure if this is the correct component, but there is no DVD option.

Description of problem:
The DVD installer hangs at the ready message, regardless of the three different
install/rescue options choosen. The boot menu appears fine, however I am left
with the following;

Loading vmlinuz......
Loading initrd.img............
Ready.

I was attempting to try this release out in regards to the new libata stuff
which I know does not work under ubuntu feisty on this machine.

I've managed to boot and do a media check of my dvd on another machine and
verified that the media is ok.

Version-Release number of selected component (if applicable):
F-6.92-i386-DVD.iso

How reproducible:
Always


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Simon Goodall 2007-04-23 13:24:54 EDT
Created attachment 153295 [details]
lspci output
Comment 2 Simon Goodall 2007-04-25 16:08:06 EDT
Created attachment 153449 [details]
disk errors

This attachment contains boot messages using latest rawhide kernel
(2.6.20-1.3104). It get stuck in a continuous loop trying to initialise the
disk. If the LiveCD/DVD kernel did the same quietly it would explain things.

The disk in question is 4+ years old, but is not a problem on the pre-libata
kernels.
Comment 3 Will Woods 2007-04-25 16:14:47 EDT
Can reproduce here on a Intel Core 2 Duo machine.

Is there already an OS on the machine? If you copy the vmlinuz / initrd from the
DVD onto /boot and add an entry in grub.conf for them, does it boot?

I'm still not quite sure if this is a bug in the kernel or in isolinux/syslinux.
Comment 4 Simon Goodall 2007-04-25 16:30:18 EDT
This machine had an old version of FC6 which I've just performed a yum update on
as I could not get the test3 livecd or dvd to work. It also has ubuntu fiesty
(running an edgy kernel for similar reasons).

I tried the FC7 test3 files and the kernel stacktraced almost immediately. I can
type up the visible part of the error if required. However, some of it has
scrolled off screen.
Comment 5 Will Woods 2007-04-26 17:38:44 EDT
Simon, your kernel stack trace is probably a separate issue from this.

Robert tried putting booting the same kernel and initrd from the on-disk GRUB
instead of the ISO, and the kernel booted. Yes, it messed up after that, but it
got past the "Ready." and that's the bug we're talking about here.

So this would appear to be a syslinux problem. Reassigning appropriately.
Comment 6 Clemens A. Schulz 2007-04-29 14:05:37 EDT
I also got the same error, if I try to boot the Install DVD or Live CD of the
FC7 TEST4 version... But... The disks don't have any error, because the disks
work great on my laptop. Only on my workstation they don't want to run... In the
past I also used Fedora Core 6 and I never had any problem with it. I also don't
know what to do now... I put all the hardware I don't need to boot off, but the
disks still don't want to run...

Do you have any other ideas?!
Comment 7 Will Woods 2007-04-30 14:28:28 EDT
(In reply to comment #6)
> I also got the same error, if I try to boot the Install DVD or Live CD of the
> FC7 TEST4 version... But... The disks don't have any error, because the disks
> work great on my laptop. Only on my workstation they don't want to run... 

Yes, it's a problem with the CD/DVD bootloader and the BIOS on those particular
machines. What model is your workstation?

> Do you have any other ideas?!

GRUB seems to boot fine on the machines we've seen this on, so if you've already
got Linux running on the machine, you can boot by copying the kernel and initrd
from the DVD into /boot and adding an entry in grub.conf for them. 
Comment 8 Boon Kui HENG 2007-05-01 07:56:53 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > I also got the same error, if I try to boot the Install DVD or Live CD of the
> > FC7 TEST4 version... But... The disks don't have any error, because the disks
> > work great on my laptop. Only on my workstation they don't want to run... 
> 
> Yes, it's a problem with the CD/DVD bootloader and the BIOS on those particular
> machines. What model is your workstation?
> 
> > Do you have any other ideas?!
> 
> GRUB seems to boot fine on the machines we've seen this on, so if you've already
> got Linux running on the machine, you can boot by copying the kernel and initrd
> from the DVD into /boot and adding an entry in grub.conf for them. 

I had exactly this problem since my first attempt with FC7 Test 3. I took the
/boot advice with FC7 Test 4 and it just worked ;) Thank you.
Comment 10 Simon Goodall 2007-06-01 04:44:18 EDT
Same problem with FC7 final

Note You need to log in before you can comment on or make changes to this bug.