Bug 237529 - X server crash after suspend on i8200 laptop (nv driver)
X server crash after suspend on i8200 laptop (nv driver)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-23 13:33 EDT by teuben
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-31 01:58:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description teuben 2007-04-23 13:33:10 EDT
Description of problem:

The X server crashes on a Dell Inspiron 8200 laptop after suspend.

Version-Release number of selected component (if applicable):

Xorg 7.1.1.

How reproducible:
Always

Steps to Reproduce:
1. login X windows
2. suspend the machine
3. wakeup the machine
  
Actual results:

X server will crash.

Expected results:

X server wakes up just as all other programs.

Additional info:

I've only been able to test this bug on a i8200, but i do have an i8500
and TP40 laptop on which i can try this. None of these would use the nv
driver though.

This bug is most likely an upstream Xorg problem, as I've seen this
also in Ubuntu. But I've tried FC6, FC7-test3 and Centos-5, they all
have this problem, the exact same way. The latest Xorg is 7.1.1.

My current FC5 does not have this problem, it uses Xorg 7.0.0 but I 
have not tracked down at what version the problems started.

An additional piece of info:  using the commercial nvidia driver
instead of the nv version that comes with Xorg makes the problem
even worse. I only tested this in FC6.

I will also start looking into the Xorg debug mode, and perhaps
a special option in /etc/sysconfig/apm-scripts/, but since i have
not found a report of this problem yet, I'd rather file it now and add
info later.
Comment 1 teuben 2007-04-24 00:42:22 EDT
Installing Ubuntu 7.04, which uses Xorg 7.2.0, confirmed that the bug has
now gone away. So, hopefully, Fedora will soon also switch to 7.2.0.
Comment 2 Matěj Cepl 2007-05-25 05:54:04 EDT
Reporter, are you able to help us with this bug, or have you finally switched
out of Fedora? If not, then I will have to close this bug.
Comment 3 teuben 2007-05-25 07:43:29 EDT
I have NOT given up on Fedora, but in studying another distrubution, Ubuntu, I
found out that the problem is indeed something upstream. In the next release
of X (7.2.0) it was solved, see my earlier not on Ubuntu 7.04. I tried FC7 test3
and it
was still using an older one that had the problem (7.1 if i recall). Haven't
tried test4, but
if the final FC7 is using the same X release as test3, yes, I'm hosed and would
probbaly have to switch to Ubuntu or stay with FC5 for a while longer.
Comment 4 Matěj Cepl 2007-05-30 20:00:19 EDT
Actually we have 7.2.0 on FC7 (with even more recent Xserver than what's in
7.2.0). Could you please upgrade and confirm whether it is still reproducible,
please?
Comment 5 teuben 2007-05-31 01:58:49 EDT
Darn, the default behavior after install is now worse actually. Suspend now
causes the screen to go fully white, not blank, but the rest of the system
appears to go into suspend (disk halts etc.). Opening the lid does give some
promising sound, but nothing comes alive.  This is with the nv driver.    I used
FC7-RC2 from end of april, the latest I could find tonight.   X is now on
version 1.3.0, the nv_drv.so for this  GeForce2 nvidia videocard is 2.0.2
Since the laptop does not want to wakeup, nothing leaves me but to reboot it.

Note You need to log in before you can comment on or make changes to this bug.