Bug 237530 - builder handling request not updated
Summary: builder handling request not updated
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora Hosted Projects
Classification: Retired
Component: plague   
(Show other bugs)
Version: unspecified
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-23 17:35 UTC by Shad L. Lords
Modified: 2007-04-27 17:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-27 17:41:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Shad L. Lords 2007-04-23 17:35:04 UTC
Description of problem:

When a builder takes a task the server never updates the database with builder name.

Version-Release number of selected component (if applicable):

0.5.0 (cvs)

How reproducible:

always

Steps to Reproduce:
1. install cvs plague
2. build package and watch task be assigned out
3. check database and see that builder_addr is still null
  
Actual results:

Because builder_addr is never set builder status page doesn't list tasks builder
is running.

Expected results:

Builder status should list tasks being worked on.

Additional info:

This change to BuildMaster.py seems to fix the issue:

--- /root/tmp/hosted/plague-0.5.0/server/BuildMaster.py 2006-05-13
23:43:07.000000000 -0600
+++ plague-0.5.0/server/BuildMaster.py  2007-04-17 15:45:47.000000000 -0600
@@ -268,8 +268,8 @@
                 print "DB Error: could not access jobs database. Reason: '%s'"
% exc
         else:
             try:
-                self._cursor.execute("UPDATE archjobs SET status='%s',
builder_status='%s', endtime=%d " \
-                    "WHERE jobid='%s' AND parent_uid=%d" % (attrdict['status'],
+                self._cursor.execute("UPDATE archjobs SET status='%s',
builder_addr='%s', builder_status='%s', " \
+                    "endtime=%d WHERE jobid='%s' AND parent_uid=%d" %
(attrdict['status'], attrdict['builder_addr'], \
                     attrdict['builder_status'], attrdict['endtime'], uid,
attrdict['parent_uid']))
             except StandardError, exc:
                 print "DB Error: could not access jobs database. Reason: '%s'"
% exc

Comment 1 Dan Williams 2007-04-27 17:41:54 UTC
committed to HEAD, thanks.


Note You need to log in before you can comment on or make changes to this bug.