Bug 237536 - pup doesn't honor the GNOME global proxy settings
Summary: pup doesn't honor the GNOME global proxy settings
Status: CLOSED DUPLICATE of bug 213402
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-23 17:59 UTC by fangorious
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-23 18:13:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description fangorious 2007-04-23 17:59:34 UTC
Description of problem:

After setting the HTTP proxy address, port, and authentication credentials in
System->Preferences->Internet and Network->Network Proxy the Software Updater
(Applications->System->Software Updater, pup) still fails.

Version-Release number of selected component (if applicable):

1.3.4-1.fc7

How reproducible:

Every time

Steps to Reproduce:
1. Connect to a network with an HTTP proxy that requires authentication (I don't
know if authentication matters or if pup ignores all GNOME global proxy
settings, my proxy needs auth so that's what I'm reporting)
2. Try to run Applications->System->Software Updater
3.
  
Actual results:

After a few minutes with no indication that anything is happening, an error
window comes up indicating failure.

Expected results:

The Software Updater GUI should come up, and then try to connect to the
repositories using the proxy information set in in GNOME.

Additional info:

Comment 1 Jeremy Katz 2007-04-23 18:13:22 UTC
pirut-1.3.5 adds the necessary bits for usermode to pass the env vars through.

*** This bug has been marked as a duplicate of 213402 ***


Note You need to log in before you can comment on or make changes to this bug.