Bug 237551 - Bootloader dialog weirdness
Bootloader dialog weirdness
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
https://www.redhat.com/archives/anaco...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-23 15:05 EDT by Felipe Contreras
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-24 00:50:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felipe Contreras 2007-04-23 15:05:14 EDT
Description of problem:
When I try anaconda from a USB key and I follow the usual steps I get into the
bootloader dialog with the wrong partition to boot into (USB key), with the
dropdown box disabled (I cannot change it), and if I try to go back I get into
the dialog where I select the "default partition" except that now the drop down
menu is disabled (also), and when trying to go to the next screen I get the
following:

 (snipped)
 /iw/autopart_type.py, line 73, in getNext
 /gui.py, line 1034, in nextClicked
 TypeError: iter must be a GtkTreeIter

Version-Release number of selected component (if applicable):
This is in f7t3.

Steps to Reproduce:
1. Try anaconda bro a bootable USB memory stick
2. Disable the USB key for installation (/dev/sda)
3. Select the internal HDD as the default and only device (SATA) (/dev/sdb)
4. [The bootloader dialog should have a greyed out dropdown menu with /dev/sda]
5. Go back
6. [The default device dialog should have a greyed out dropdown menu with nothing]
7. Go forward
8. Crash
Comment 1 Jeremy Katz 2007-04-24 00:50:12 EDT
Okay, looking at this it looks like the case that I've fixed after test3

Note You need to log in before you can comment on or make changes to this bug.