Bug 237585 - USB Flash Drives in Fedora 7 Read Only
USB Flash Drives in Fedora 7 Read Only
Status: CLOSED DUPLICATE of bug 234716
Product: Fedora
Classification: Fedora
Component: gnome-mount (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-23 17:30 EDT by Gerald Cox
Modified: 2013-03-05 22:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 19:53:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Cox 2007-04-23 17:30:06 EDT
Description of problem:
Runinng F7 Test 3 and found that USB drives when
inserted are read-only.  The way I had corrected this was to
create an entry in FSTAB; but I thought that this was suppose to be
handled automatically.  

I have a FC6 system and don't have any entries in
FSTAB and it works
correctly.

Owner and group are both Root.

Version-Release number of selected component (if applicable):
Lastest maintenance for Fedora 7 Test 3 applied.

How reproducible:
Every time USB Flash Drive is inserted.


Steps to Reproduce:
1.  Insert USB Drive
2.  Try to write to USB Drive.
  
Actual results:

Device write protected.


Expected results:

Device writable.


Additional info:
Comment 1 tracyde 2007-04-25 13:25:44 EDT
I also have the same issue and fixed it by entering the appropriate fstab
entries.  The expected result is for the removable drive to be mounted as
read/write for the user or a particular group.
Comment 2 William Murray 2007-04-25 17:00:35 EDT
Same for me. ext2 usb pen on an x86_64 FC7.
This is a significant issue.

Possibly related?? A CD-RW with data on it cannot be erased by nautilus
because it is mounted. But nautilus cannot umount, only eject. So you
need to know what you are doing to erase this.
Comment 3 David Zeuthen 2007-04-25 19:53:55 EDT
(In reply to comment #2)
> Same for me. ext2 usb pen on an x86_64 FC7.
> This is a significant issue.

Uh, there's no way to use uid= on ext2/ext3 since uid/gid are encoded in the
file system itself. The original bug report was for fat I assume so I will close
this bug as a duplicate.

> Possibly related?? A CD-RW with data on it cannot be erased by nautilus
> because it is mounted. But nautilus cannot umount, only eject. So you
> need to know what you are doing to erase this.

The way it works is that nautilus-cd-burner automatically unmounts before
erasing and asking for confirmation whether you really want to erase the data
that is on the disc already. If it doesn't work this way, please file a bug
against nautilus-cd-burner.


*** This bug has been marked as a duplicate of 234716 ***

Note You need to log in before you can comment on or make changes to this bug.