Bug 237649 - [fix available] impress crash
Summary: [fix available] impress crash
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-24 14:30 UTC by Rod Nayfield
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0849
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 16:56:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
likely patch for this (2.41 KB, patch)
2007-04-24 14:47 UTC, Caolan McNamara
no flags Details | Diff
OOffice crash on Undo (5.86 KB, text/plain)
2007-05-15 13:27 UTC, Michal Babej
no flags Details
traceback (4.09 KB, text/plain)
2007-05-29 15:06 UTC, Nicole Dai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0849 normal SHIPPED_LIVE Openoffice.org bug fix update 2007-11-20 22:26:32 UTC
OpenOffice.org 69010 None None None Never

Description Rod Nayfield 2007-04-24 14:30:26 UTC
Description of problem:

OOo crashes randomly, often.

Version-Release number of selected component (if applicable):

openoffice.org-core-2.0.4-5.4.17.1

How reproducible:

randomly

Steps to Reproduce:
1. Seems to happen when deleting text, but that could be just a guess
  

Additional info:
(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers/i810_drv.so
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.1-52.el5.2-i386
(V)    kernel is: Linux 2.6.18-8.1.1.el5.rod #1 SMP Fri Apr 13 13:02:43 EDT 2007
i686 i686 i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-5.4.17.1-i386
(VII)  depth of root window:    24 planes
(VIII) accessibility is: false
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
0x750eee8: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x22ee8
0x750fb7b: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x23b7b
0x699420:  + 0x420 (__kernel_sigreturn + 0x0)
0x58d1356: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0x2eb356
0x58d0eb6: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0x2eaeb6
(SfxUndoManager::AddUndoAction(SfxUndoAction*, unsigned char) + 0xf6)
0x70176bc: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x27d6bc
0x58d12ec: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0x2eb2ec
(SfxUndoManager::EnterListAction(String const&, String const&, unsigned short) +
0x9c)
0x7017747: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x27d747
0x68ce2f7: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x7552f7
(SdrModel::BegUndo(String const&) + 0x57)
0x6ee2e22: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x148e22
0x6ee2e56: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x148e56
0x6f68dd4: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x1cedd4
0x6e8d751: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0xf3751
0x6edc440: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x142440
0x6e9489a: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0xfa89a
0x3d6c12b: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x28012b
0x3d6e199: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x282199
0xb0f895: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x34895
0xb13151: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x38151
0x379f020: /usr/lib/libgtk-x11-2.0.so.0 + 0x130020
0x109f0b: /lib/libgobject-2.0.so.0 + 0x8f0b (g_closure_invoke + 0x12b)
0x11ae83: /lib/libgobject-2.0.so.0 + 0x19e83
0x11c147: /lib/libgobject-2.0.so.0 + 0x1b147 (g_signal_emit_valist + 0x667)
0x11c539: /lib/libgobject-2.0.so.0 + 0x1b539 (g_signal_emit + 0x29)
0x38b30e8: /usr/lib/libgtk-x11-2.0.so.0 + 0x2440e8
0x37984fa: /usr/lib/libgtk-x11-2.0.so.0 + 0x1294fa (gtk_propagate_event + 0x1ba)
0x37996c7: /usr/lib/libgtk-x11-2.0.so.0 + 0x12a6c7 (gtk_main_do_event + 0x317)
0x35f0ffa: /usr/lib/libgdk-x11-2.0.so.0 + 0x40ffa
0xd5a342: /lib/libglib-2.0.so.0 + 0x2b342 (g_main_context_dispatch + 0x182)
0xd5d31f: /lib/libglib-2.0.so.0 + 0x2e31f
0xd5d885: /lib/libglib-2.0.so.0 + 0x2e885 (g_main_context_iteration + 0x65)
0xaecc61: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x11c61
0x2257b7: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x517b7
(X11SalInstance::Yield(bool, bool) + 0x37)
0x3b81708: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x95708
(Application::Yield(bool) + 0x68)
0x3b817dc: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x957dc
(Application::Execute() + 0x3c)
0x4410279: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x26279
(desktop::Desktop::Main() + 0x1779)
0x3b872ac: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x9b2ac
0x3b873b5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x9b3b5 (SVMain()
+ 0x35)
0x4401979: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x17979 (sal_main
+ 0x59)
0x4401a04: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x17a04 (main + 0x44)
0xb9ddec: /lib/libc.so.6 + 0x15dec (__libc_start_main + 0xdc)
0x80484a1: /usr/lib/openoffice.org2.0/program/simpress.bin + 0x4a1
...end stackreport details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0x00da8000)
	libuno_sal.so.3 => /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 (0x006b1000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org2.0/program/libuno_salhelpergcc3.so.3 (0x002fd000)
	libstore.so.3 => /usr/lib/openoffice.org2.0/program/libstore.so.3 (0x0097a000)
	libdl.so.2 => /lib/libdl.so.2 (0x001ec000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x003e7000)
	libstlport_gcc.so => /usr/lib/openoffice.org2.0/program/libstlport_gcc.so
(0x00f0c000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x001f0000)
	libm.so.6 => /lib/libm.so.6 (0x005de000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00110000)
	libc.so.6 => /lib/libc.so.6 (0x00a4d000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x00d39000)
	/lib/ld-linux.so.2 (0x001b9000)
...end sample ldd details ...

Comment 1 Caolan McNamara 2007-04-24 14:42:45 UTC
From the stack it's adding something to the undo which causes this,

Is this from impress, or from draw ? It might help to know what view you are
using if this is impress, e.g. notes view, outline view or normal.

Comment 2 Caolan McNamara 2007-04-24 14:47:35 UTC
Created attachment 153357 [details]
likely patch for this

This is the likely patch for this.

Comment 3 Caolan McNamara 2007-04-24 14:48:56 UTC
5.1.0 planning and bug selection is over, so proposing for 5.2.0

Comment 4 Rod Nayfield 2007-04-24 18:21:42 UTC
Yes, it is impress (the presentation tool) and I am in outline mode.

Does this only happen in outline mode?


Comment 5 RHEL Product and Program Management 2007-04-24 18:43:43 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 9 Rod Nayfield 2007-05-03 20:31:25 UTC
Yes I will test it myself.

Additionally, you can try to reproduce this by:

1) opening an existing relatively big presentation
2) switching to outline mode
3) making rapid changes to the outline, specifically deleting text and changing
outline levels of items, etc.

I don't quite grok the patch cause I don't know ooo well, but I would think that
it's a combination of adding to the undo list that does this, with outline mode
specifically 



Comment 11 Caolan McNamara 2007-05-03 21:08:12 UTC
build underway

Comment 13 Caolan McNamara 2007-05-09 09:16:29 UTC
Packages are in /mnt/redhat/brewroot/packages/openoffice.org/2.0.4/5.4.22 if
this works, please set to "verified"

Comment 14 Satyabrata Maitra 2007-05-09 09:26:56 UTC
Hi Nayfield

I tested it for OOo version openoffice.org-core-2.0.4-5.4.17.1 with en_US, bn_IN
locales. But Could not reproduce it still. :(
May I request you to provide some more information how it was reproduced, and
any special action that performed to reproduce it.
I performed it with a huge document in en_US and bn_IN, in outline mode and
tried to delete it both with Delete and Backspace key, and did repeated Undo. No
how it reproduced. Please provide informations or test steps to follow.

Comment 16 Michal Babej 2007-05-15 13:27:52 UTC
Created attachment 154734 [details]
OOffice crash on Undo

Comment 17 Caolan McNamara 2007-05-15 13:35:31 UTC
You have accessibility enabled.  Can you repeat your tests without accessibility
enabled. There are very likely accessibility bugs, and I'm more than willing to
fix these given the various acks, but the original report is of undo in a non
accessible environment, so testing with a11y enabled is more a test of a11y than
a test of this problem and might be showing a different problem.

Comment 18 Michal Babej 2007-05-15 15:25:06 UTC
sure, no prob.

Comment 19 Michal Babej 2007-05-16 10:34:50 UTC
without a11y, i could not reproduce it either.

Comment 20 Caolan McNamara 2007-05-16 10:49:17 UTC
oky doky, well I suggest that we'll have to take this on trust then :-) The
patch looks correct to me.

mbabej: If you want to repeat the *a11y* tests on FC-7/rawhide and see if they
still exist and file bugs if so that'd be great, then I'll take a look at that
separate but also important problem.

Comment 21 Nicole Dai 2007-05-29 15:06:09 UTC
Created attachment 155596 [details]
traceback

Reproduced twice the crash with openoffice.org-2.0.4-5.4.17 on x86_64 and once
on i386 when I executed the steps in Comment #9 with the slides got from
Comment #15 five times. After upgrade to openoffice.org-2.0.4-5.4.22 I did not
find the crash in five times execution.

Comment 22 Caolan McNamara 2007-05-31 17:55:00 UTC
Reproduced twice the crash with openoffice.org-2.0.4-5.4.17 -> After upgrade to
openoffice.org-2.0.4-5.4.22 I did not find the crash -> setting to verified if
no-one disagrees

Comment 24 errata-xmlrpc 2007-11-07 16:56:51 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0849.html



Note You need to log in before you can comment on or make changes to this bug.