Bug 2376521 - netatalk atalkd fails to start because of missing lock directory
Summary: netatalk atalkd fails to start because of missing lock directory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: netatalk
Version: 42
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Andrew Bauer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2025-07-05 18:08 UTC by Adam Goode
Modified: 2025-07-14 22:51 UTC (History)
3 users (show)

Fixed In Version: netatalk-4.2.4-1.fc43 netatalk-4.2.4-1.fc42
Clone Of:
Environment:
Last Closed: 2025-07-05 21:32:32 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Adam Goode 2025-07-05 18:08:58 UTC
See also https://github.com/Netatalk/netatalk/issues/1759.

atalkd fails to start on bootup, though it can be started later.

It looks like /run/lock/netatalk doesn't exist until later, when netatalk runs (if configured).

You probably need to add RuntimeDirectory entries for all the systemd unit files.

Or, another reasonable solution would be to change https://src.fedoraproject.org/rpms/netatalk/blob/rawhide/f/netatalk.spec#_171 to use just `%{_rundir}/lock` instead of `%{_rundir}/lock/netatalk`, since `/run/lock` is always created by systemd.


Reproducible: Always

Steps to Reproduce:
1. Install netatalk
2. Enable atalkd.service

Actual Results:
Jul 05 13:08:22 lincoln5 systemd[1]: Starting atalkd.service - Netatalk AppleTalk daemon...
Jul 05 13:08:23 lincoln5 atalkd[1260]: atalkd: can't open lock file, "/run/lock/netatalk/atalkd"
Jul 05 13:08:23 lincoln5 systemd[1]: atalkd.service: Control process exited, code=exited, status=1/FAILURE
Jul 05 13:08:23 lincoln5 systemd[1]: atalkd.service: Failed with result 'exit-code'.
Jul 05 13:08:23 lincoln5 systemd[1]: Failed to start atalkd.service - Netatalk AppleTalk daemon.

Comment 1 Andrew Bauer 2025-07-05 19:12:00 UTC
Yeah, I am the author of that github issue. 

If any of the appletalk services are started before the netatalk service, then they will fail as shown. You are right, a RunTimedirectory clause should get added to all the appletalk services similar to this:
https://src.fedoraproject.org/rpms/netatalk/blob/rawhide/f/netatalk.spec#_163

Let me know how well the services in the appletalk subpackage work. I simply don't have any pre OS X macs lying around to test them.

Comment 2 Fedora Update System 2025-07-05 21:30:07 UTC
FEDORA-2025-b727df0295 (netatalk-4.2.4-1.fc43) has been submitted as an update to Fedora 43.
https://bodhi.fedoraproject.org/updates/FEDORA-2025-b727df0295

Comment 3 Fedora Update System 2025-07-05 21:32:32 UTC
FEDORA-2025-b727df0295 (netatalk-4.2.4-1.fc43) has been pushed to the Fedora 43 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 4 Fedora Update System 2025-07-05 21:33:29 UTC
FEDORA-2025-79b07382d1 (netatalk-4.2.4-1.fc42) has been submitted as an update to Fedora 42.
https://bodhi.fedoraproject.org/updates/FEDORA-2025-79b07382d1

Comment 5 Fedora Update System 2025-07-06 00:59:09 UTC
FEDORA-2025-79b07382d1 has been pushed to the Fedora 42 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2025-79b07382d1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2025-79b07382d1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Adam Goode 2025-07-06 01:58:51 UTC
Thanks, I will try this!

Comment 7 Fedora Update System 2025-07-14 22:51:24 UTC
FEDORA-2025-79b07382d1 (netatalk-4.2.4-1.fc42) has been pushed to the Fedora 42 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.