Bug 237654 - two power icons in kde tray with livecd
Summary: two power icons in kde tray with livecd
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: LiveCD   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Sebastian Vahl
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-04-24 14:57 UTC by Jeremy Katz
Modified: 2013-01-10 04:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-10 13:06:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2007-04-24 14:57:01 UTC
With the KDE livecd, I'm ending up with two power icons in the systray; it looks
like one is klaptop and the other is kpowersave.  This is probably not what we
really want

Comment 1 Sebastian Vahl 2007-04-24 16:11:31 UTC
Ah. Thanks for mention it (don't own a laptop). kpowersave is set as "default" 
in extra's comps.xml. We could manually exclude kpowersave on the livecd. But 
maybe it should be set as "optional" in comps.xml.

Comment 2 Rex Dieter 2007-04-24 16:52:28 UTC
kpowersave is what we want, and needs to stay.

klaptop will be gone asap as soon as kde is moved to Extras... hint, hint.
In the meantime, than is working on that.

Comment 3 Sebastian Vahl 2007-04-24 17:18:11 UTC
Ah, Ok. Chtilesh also mentioned this but I wasn't shure because klaptop is not 
mentioned here: http://fedoraproject.org/wiki/Releases/FeatureFedoraKDE

What would you suggest until split is done: Leave klaptop and kpowersave on 
the livecd (to test kpowersave) or exclude kpowersave for test4?

Comment 4 Jeremy Katz 2007-04-24 17:28:27 UTC
(In reply to comment #3)
> What would you suggest until split is done: Leave klaptop and kpowersave on 
> the livecd (to test kpowersave) or exclude kpowersave for test4?

Hopefully the test4 spin is done (my fingers are crossed...).  We definitely
want it cleaned up for final, but it doesn't really qualify as a test4 blocker

Comment 5 Rex Dieter 2007-04-24 17:39:32 UTC
ooops, klaptop isn't on the wiki (my bad), but we did discuss it in several KDE
SIG irc meetings.

As I said, kpowersave needs to stay.  omitting it isn't(shouldn't) be an option.

Comment 6 Florian La Roche 2007-05-09 13:20:49 UTC
We should stay with the upstream and more tested klaptop and then change over
with KDE4 to newer/other versions if appropriate.

regards,

Florian La Roche


Comment 7 Sebastian Vahl 2007-05-09 20:44:43 UTC
(In reply to comment #6)
> We should stay with the upstream and more tested klaptop and then change over
> with KDE4 to newer/other versions if appropriate.

I have no opinion in this point because I don't own a laptop to compare these
two. So not including kpowersave would also be fine for me.

Rex?



Comment 8 Rex Dieter 2007-05-09 21:12:06 UTC
klaptop decreases battery life by as much as 50% (due to it's polling 
of /proc/...), kpowersave doesn't and is dbus-aware to boot.  It is (should be) 
a no-brainer to go with kpowersave.

We've discussed this topic in several KDE SIG meetings already.

Comment 9 Sebastian Vahl 2007-05-10 13:06:12 UTC
Next rawhide push will split klaptop into kdeuitls-extras. So on the livecd only
kpowersave will remain.

kdeutils is tagged as "f7-final", so I close this bug.

http://koji.fedoraproject.org/koji/buildinfo?buildID=6424


Note You need to log in before you can comment on or make changes to this bug.