Bug 237687 - convmv fails to build from sources
convmv fails to build from sources
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: convmv (Show other bugs)
5.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Nils Philippsen
QE Internationalization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-24 15:27 EDT by giuseppe bonacci
Modified: 2010-10-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-27 10:56:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch for (testsuite.tar)suite/dotests.sh (2.89 KB, patch)
2007-04-26 09:36 EDT, giuseppe bonacci
no flags Details | Diff

  None (edit)
Description giuseppe bonacci 2007-04-24 15:27:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070310 Iceweasel/2.0.0.3 (Debian-2.0.0.3-1)

Description of problem:
when rpmbuild-ing the source rpm, the test suite fails. 

the reason is that the output from a "find" is compared to the output taken on a reference system.  the output lines are fine, except that usually the ordering differs, and that's ok.  before comparing, the test script should sort both the reference output and the observerd results, because find does not guarantee a fixed order. 

Version-Release number of selected component (if applicable):
convmv-1.10-1.el5.src.rpm

How reproducible:
Always


Steps to Reproduce:
1. rpmbuild --rebuild convmv-1.10-1.el5.src.rpm

Actual Results:


Expected Results:


Additional info:
Comment 1 giuseppe bonacci 2007-04-26 09:36:58 EDT
Created attachment 153510 [details]
proposed patch for (testsuite.tar)suite/dotests.sh
Comment 3 Jens Petersen 2007-08-22 22:09:42 EDT
I think "LANG=C make test" should fix this.

Also it should be moved to %check.
Comment 4 giuseppe bonacci 2007-08-23 06:16:47 EDT
Jens, 
I tried to prepend LANG=C.  "make test" was already in '%check'. 

however, it did not work.  (BTW, I already build with LANG=C).

as far as I can tell, the locale does not matter.  the problem is due to the
assumption in dotests.sh that the list of filenames output by find is ordered 
exactly like in testsuite.tar.  generally, this is not the case: the order from 
find is unspecified.

is there any reason against the patch I submitted?  does it break something else?
Comment 5 Nils Philippsen 2007-09-27 10:56:27 EDT
I've applied your patch and moved "make test" to %check in the current Rawhide
version. I don't think we'd get the buy-in needed to warrant pushing a new
package version through for RHEL5 though.

Note You need to log in before you can comment on or make changes to this bug.