Bug 2377 - dump fails, claiming corruption of FS which passes fsck
dump fails, claiming corruption of FS which passes fsck
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: dump (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-26 16:10 EDT by haas
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-30 19:28:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haas 1999-04-26 16:10:50 EDT
[root@beavis /root]# /sbin/dump 4ubBf 32 24000000 /dev/tape
/dev/sda2
  DUMP: Date of this level 4 dump: Mon Apr 26 13:14:14 1999
  DUMP: Date of last level 0 dump: Tue Feb 23 16:54:11 1999
  DUMP: Dumping /dev/sda2 (/) to /dev/tape
  DUMP: mapping (Pass I) [regular files]
  DUMP: estimated 280057 tape blocks on 0.01 tape(s).
  DUMP: dumping (Pass III) [directories]
/dev/sda2: EXT2 directory corrupted while converting
directory #2

  DUMP: Broken pipe
[root@beavis /root]# rpm -q dump
dump-0.3-17

HARDWARE IS:
Apr 26 09:11:57 beavis kernel: (scsi0) <Adaptec AIC-7890/1
Ultra2 SCSI host adap
ter> found at PCI 6/0
Apr 26 09:11:57 beavis kernel: (scsi0) Wide Channel, SCSI
ID=7, 32/255 SCBs
Apr 26 09:11:57 beavis kernel: (scsi0) Downloading sequencer
code... 407 instruc
tions downloaded
Apr 26 09:11:57 beavis kernel: scsi0 : Adaptec
AHA274x/284x/294x (EISA/VLB/PCI-F
ast SCSI) 5.1.4/3.2.4
Apr 26 09:11:57 beavis kernel:        <Adaptec AIC-7890/1
Ultra2 SCSI host adapt
er>
Apr 26 09:11:57 beavis kernel: scsi : 1 host.
Apr 26 09:11:57 beavis kernel:   Vendor: IBM       Model:
DRVS09V           Rev:
 00F0
Apr 26 09:11:57 beavis kernel:   Type:
Direct-Access                      ANSI
 SCSI revision: 03
Apr 26 09:11:57 beavis kernel: Detected scsi disk sda at
scsi0, channel 0, id 0,
 lun 0
Apr 26 09:11:57 beavis kernel:   Vendor: IBM       Model:
DRVS09V           Rev:
 0100
Apr 26 09:11:57 beavis kernel:   Type:
Direct-Access                      ANSI
 SCSI revision: 03
Apr 26 09:11:57 beavis kernel: Detected scsi disk sdb at
scsi0, channel 0, id 1,
 lun 0
Apr 26 09:11:57 beavis kernel:   Vendor: HP        Model:
C1537A            Rev:
 L708
Apr 26 09:11:57 beavis kernel:   Type:
Sequential-Access                  ANSI
 SCSI revision: 02
Apr 26 09:11:57 beavis kernel: Detected scsi tape st0 at
scsi0, channel 0, id 3,
 lun 0
Apr 26 09:11:57 beavis kernel: scsi : detected 1 SCSI tape 2
SCSI disks total.
Apr 26 09:11:57 beavis kernel: (scsi0:0:0:0) Synchronous at
20.0 Mbyte/sec, offs
et 15.
Apr 26 09:11:57 beavis kernel: SCSI device sda: hdwr sector=
512 bytes. Sectors=
 17928698 [8754 MB] [8.8 GB]
Apr 26 09:11:57 beavis kernel: (scsi0:0:1:0) Synchronous at
20.0 Mbyte/sec, offs
et 15.
Apr 26 09:11:57 beavis kernel: SCSI device sdb: hdwr sector=
512 bytes. Sectors=
 17928698 [8754 MB] [8.8 GB]
Comment 1 Jeff Johnson 1999-04-27 16:24:59 EDT
Can you make sure that
	1) the file system has  been fsck'd. It's not enough to
	rely on the fsck run during reboot -- you will need to run
	e2fsck with the -f flag.
	2) The file system that you are dumping is "quiet". Ideally
	dump should be run with an unmounted file system.
	3) Check /var/log/messages for disk hardware errors.

You might also try recompiling and running dump-0.4 from
rawhide.redhat.com to see whether there is a dump problem
that has been fixed already.
Comment 2 Jeff Johnson 1999-05-04 11:49:59 EDT
Did dump-0.4 help your problem>
Comment 3 Preston Brown 2000-06-27 12:22:55 EDT
closed due to lack of feedback.  Likely user error or fixed in current release.

Note You need to log in before you can comment on or make changes to this bug.